Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run the Virtualbox web service but I cannot start it.

When I run vboxwebsrv this is the output:

Oracle VM VirtualBox web service Version 4.2.4_Gentoo_
(C) 2007-2012 Oracle Corporation
All rights reserved.
vboxwebsrv: error: failed to open release log (mmap(PROT_WRITE | PROT_EXEC) failed -- SELinux?, VERR_NO_MEMORY)

I cannot find similar problems on the Internet.

Virtualbox is compiled with the following use flags: "additions -alsa -doc extensions headless java opengl pam -pulseaudio python -qt4 sdk vboxwebsrv -vnc"

I am running a hardened kernel (didn't compile virtualbox with a hardened version of gcc though).

share|improve this question

migrated from serverfault.com Nov 14 '12 at 20:41

This question came from our site for professional system and network administrators.

1 Answer 1

The error you're getting tells me it can't open a log file for writing or can't open the folder it should be in.

Try creating the log file and set the right permissions, e.g.:

touch /var/log/vboxweb.log; chown vbox:vboxusers /var/log/vboxweb.log
share|improve this answer
    
The file /var/log/vboxweb.log exists and I'm executing vboxwebsrv as root. Still getting the same error. I also tried supplying --logfile /var/log/vboxweb.log to the vboxwebsrv command but this also didn't do the trick. –  siebz0r Nov 14 '12 at 23:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.