Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I asked this question on Server fault and was told that was not allowed so I am moving it here.

I am running Windows Server 2008 enterprise in my HOME network inside of VMware workstation. I am running this on my home network to setup a PPTP VPN connection at home. I have correctly setup everything I needed to make it work, including opening all the ports, 1723 and 43 (GRE). I am able to connect just fine, but when I connect I do not have internet unless I uncheck use remote gateway. The thing is, I want to use the remote gateway to route all my traffic through that connection. Can someone tell me why this is not working and how to get it to work. When I have remote gateway checked, and I do an ipconfig I do not get a remote gateway for the VPN connection, its 0.0.0.0 when id assume if connected properly should be 192.168.1.254 (my ATT Home Router).

Also, if I cant get the remote gateway issue to work, and I have to uncheck that box to get internet, does this mean my VPN session is no longer encrypted? I am fully aware the PPTP VPN is the weakest VPN encryption out there but still having that extra layer of security when I am on an unsecure wifi connection makes me feel a bit better. Thank you for all your help in advance.

Someone told me I need to setup a gateway or router configured on the server. If that is the case, how go I go about telling the remote co

share|improve this question

1 Answer 1

go to dns manager -> rightclick+properties your DNS Server -> interfaces -> check if DNS responds to the pptp Interface.

share|improve this answer
    
DNS is handled by my home router, the server simply does VPN. I think i figured it out though. I opened the routing and remote access, expanded ipV4 and right clicked general and clicked "new interface" and selected local connection and selected NAT. From there I selected to allow internet to be routed through this gateway. It appears to be working my iphone, I will have to further test with a computer later. –  Mike K Nov 15 '12 at 0:23
    
Essentially in this link and what is under configure routing and remote access. support.microsoft.com/kb/816581 –  Mike K Nov 15 '12 at 0:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.