Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed tftp as per this document: http://icesquare.com/wordpress/solvedtftp-error-code-2-access-violation/

I followed this to the letter 3 times and every time I put a file I get:

root@CiscoCFG:~# tftp localhost tftp> put test Error code 2: Access violation tftp> root@CiscoCFG:~# tftp localhost tftp> put test Error code 2: Access violation

If I touch the file name chmod 777 the file then do a put it works perfectly fine.

My config is as follows:

service tftp { protocol = udp port = 69 socket_type = dgram wait = yes user = nobody server = /usr/sbin/in.tftpd server_args = -s /svr/tftp disable = no }

the directory /svr/tftp permissions are 777: drwxrwxrwx 3 nobody nobody 4096 Nov 14 10:32 svr

This thing should have full permissions as would anyone who wanted to write or read from that directory. I see nothing in the logs im really stumped on this. If the file is already in the directory I can read it all day long, I just cant make NEW files, can not put them, but I can do get's, I can only put to an existing file with permissions @777.

Thanks

share|improve this question
    
you didn't follow the instructions to the letter; "server_args = -s /svr/tftp" should be "server_args = svr/tftp -s" –  Pat Nov 16 '12 at 13:24
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.