Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

enter image description here

All of a sudden, my Microsoft Office files have the generic file icon, and it happens with Powerpoint and Word, but not Excel. I can open the files just fine, and I tried restarting my computer, creating new files, clicking F5 on the desktop, turning off my Windows XP theme patcher, and none of them worked, any ideas?

EDIT: I've also noticed that it happened to the following programs: Windows Live Messenger, iTunes, and Skype, so not just MS Office. Yet, some are still fine like IE, Paint, GIMP, Paint.NET, a few web browsers, etc.

I tried using ShellExView, and there were only two that happened on a date close to when the icons went crazy, and they were both on that date (Nov 15), but as for the modified date, none were even recent. I disabled them, and restarted Windows Explorer, but it didn't work. enter image description here

share|improve this question
    
I suspect your registry is hosed. –  Daniel R Hicks Nov 27 '12 at 20:47
add comment

13 Answers

You only explicitly mention the desktop. Are files in other folders affected?


Try deleting any thumbs.db file that exists. You may have to enable the display of hidden and system files to see it. Those files are safe to delete (thumbnail cache) and will be automatically regenerated by Windows.


This may be caused by a faulty shell extension. Have you installed anything recently?

Take a look at installed shell extensions with ShellExView.

  1. Go to Options => Filter By Extension Type; hold shift and select Icon Handler, Icon Overlay Handler and Thumbnail. Is there anything there that was recently installed?

  2. Try sorting by the File Created Time and CLSID Modified Time columns. Any items modified around the time you first noticed this?

  3. You can safely disable shell extensions to test, using the right click context menu. You may need to restart explorer.exe to force it to reload/unload any changed extensions.


  • You could try a repair installation of Microsoft Office. There is a chance that the icon files, etc., got corrupted and a repair installation should fix that. You might need to do so from the installation DVD if you have deleted the cached installation files (which are quite large).

  • You may also wish to run sfc /scannow to verify and repair any corrupted or missing system files.

  • You could also try a System Restore to a point before this first started happening. There is a chance that a Windows update corrupted necessary files, especially if an unclean shutdown occurred.

share|improve this answer
    
I couldn't find any thumbs.db files, but somebody else recomended all files ending in .db, which fixed the icons for a few programs, but most are still broken. As for the ShellExView, I followed your instructions and disabled them, but it didn't work. Check out my edit for my details on that... I tried repair installation, but the installer literally opens, waits 5 seconds, then closes forever. As for the "sfc /scannow", it didnt fix it, but it removed my ability to use my hacked Windows XP theme, so thanks a lot for that :p . –  leaf68 Nov 26 '12 at 0:41
    
I also tried the Restore Point on the day that it happened, it broke more than it fixed :/ –  leaf68 Nov 26 '12 at 0:41
    
@leaf68 Were you using the installation DVD to perform the repair? Have you tried a reinstall (uninstall + install)? –  Bob Nov 26 '12 at 4:19
    
I got it online so I don't have a CD, I have a download link. But yes, I tried the download link installer to repair. –  leaf68 Nov 26 '12 at 22:20
add comment

Terminate Windows Explorer, erase the centralized thumbnail cache by deleting all of the files ending in .db in the %UserProfile%\AppData\Local\Microsoft\Windows\Explorer folder, then restart the Explorer process. This can easily be done using a batch script (you may need to close other programs first):

taskkill /f /im explorer.exe
cd %UserProfile%\AppData\Local\Microsoft\Windows\Explorer
del *.db
explorer

Note that you can also use CCleaner to do this.

I've dealt with this before and it usually comes down to corruption of the thumbnail cache. Though I'm not exactly sure about this, cleaning the registry using CCleaner may also help.


Update

Try deleting all of the Thumbs.db files in your entire user folder using this script (don't worry, I've actually tested these commands :-)):

cd %UserProfile%
del /a:h /s Thumbs.db

You can integrate these commands into the first script, producing the following:

taskkill /f /im explorer.exe
cd %UserProfile%\AppData\Local\Microsoft\Windows\Explorer
del *.db
cd %UserProfile%
del /a:h /s Thumbs.db
explorer

Update 2

Try this:

del %UserProfile%\AppData\Local\IconCache.db

I've revised the script to make it more elegant and add the above command (in a modified form):

taskkill /f /im explorer.exe
cd %UserProfile%
del AppData\Local\Microsoft\Windows\Explorer\*.db
del AppData\Local\IconCache.db
del /a:h /s Thumbs.db
explorer

See KB2936571: Icons change incorrectly in Windows.

share|improve this answer
    
+1 because the batch script fixed skype, and a few other programs, but it still didn't fix MS Office :/ –  leaf68 Nov 25 '12 at 6:27
    
@leaf68: See update. –  DragonLord Nov 26 '12 at 2:46
    
That deleted something but the icons didn't change :( –  leaf68 Nov 26 '12 at 22:19
    
@leaf68, the problem is in the icon cache, not the thumbnail cache. See my second update; this should solve the problem. –  DragonLord Nov 27 '12 at 20:44
    
@leaf68, are you online? –  DragonLord Nov 30 '12 at 2:51
show 1 more comment

Oddly enough, Office programs don’t seem to have a user-friendly, built-in associate file-types function like pretty much every other program. Nevertheless, there are a few ways to restore the Office file-type association (though be aware that .docx is also used by WordPad in Windows 7, not just Office).

share|improve this answer
    
I already tried that, and the weird thing is, it opens with Word by default anyway, but the icons wont show up right. I even tried changing it to WordPad and then back to Word, and it still didn't work –  leaf68 Nov 25 '12 at 6:32
    
You tried what? I listed three things. The first and third options may or may not help with the icon, but the second one should. –  Synetech Nov 25 '12 at 15:25
    
But all 3 of them do the same thing? I tried the first and second one. The files open with Word when I open them, but the icons are still the same as before. –  leaf68 Nov 25 '12 at 23:59
    
> But all 3 of them do the same thing? Not quite. The first and third methods simply changes registry settings to use the specified program to open a file and sets the icon manually. The second method—I should probably rearrange them—uses the program itself to associate its file-types. This is the best method because file association is not necessarily a simple matter of setting .xxx = blah.exe; many programs like browsers and most Microsoft programs have use extensive, complex methods with all kinds of hooks and registry entries to set file associations. –  Synetech Nov 26 '12 at 1:15
    
The icon for Office programs may not be as simple as DefaultIcon=winword.exe; it may/probably be done through an icon handler, which allows for things like previews in thumbnail-mode (I am almost certain that Office files do in fact have icon-/preview-handlers). As such, you really need to have the program itself re-register its associated file-types to do it correctly. –  Synetech Nov 26 '12 at 1:17
show 2 more comments

IF word and power point are still installed you need to reassociate the file type to the program, something stole it. Right click on the file > open with > choose default program(or select program) > find word/powerpoint in the list and make sure the checkbox next to always use this program to open this file is checked and click ok.

Fix File association walk through

If word or powerpoint are no longer installed you will have to reinstall them.

share|improve this answer
    
I already tried that, the file opens with word by default already when I double click it as well –  leaf68 Nov 16 '12 at 22:53
    
Have you tried doing a repair install of office? method 2 most likely support.microsoft.com/kb/924611 –  Phillip R. Nov 17 '12 at 3:27
    
Several times... ecah time the uinstall window opens up, "Please wait while setup prepares necessary files." the closes 2-3 seconds later. –  leaf68 Nov 17 '12 at 3:50
add comment

If your MSOFFICE (or any application) is installed on a different disk than your OS and that disk becomes unavailable or very latent, icons will behave this way.

share|improve this answer
    
It's installed on my local hard drive, sadly. –  leaf68 Nov 22 '12 at 4:21
    
I know it sounds crazy, but you may want to see if your HD is having problems or not well connected. I had similar problems on SSD a year ago. It turned out to be the connection. –  Fergus Nov 22 '12 at 4:43
    
it seems really hard to believe that a faulty connection could cause only certain files to act weird every single time...but is there a way I could test this without opening up my computer? –  leaf68 Nov 25 '12 at 6:29
add comment

It seems to me the problem is missing Installer files.

Are you running low on disk space? Have you tried making some space by deleting files?

That was the cause when it happened to me. I don't remember the exactly folder, but it was C:\Windows\$hf_mig$ if I'm not mistaken.

I don't think there's an easy way to correct that. You can try to restore from a restore point, created before Nov 15. Have you tried that?

share|improve this answer
    
+1 you can definitely cause this problem by deleting C:\Windows\Installer (I know from experience...) –  Colin Pickard Feb 25 at 21:12
add comment

I assume your system might be infected by some Spyware which has changed the registry values. This might have happened during install of any new software or toolbars. System restore is also an open option but then you will also lose some of your data.

In my opinion you can use the free edition of SuperAntiSpyware Utility available here- www.superantispyware.com

This util is clean and is frequently advised by MVPs on microsoft official forums to check for Spywares. All you have to do is to install and run this util and it will prompt you the registry changes(if any) before repairing it automatically for you.

share|improve this answer
add comment

Download Nirsoft FileTypesMan, unpack into a folder and launch the exe.
Double-click on the .docx entry and examine the default icon entry.

My own icon entry for Word 2010 Professional Plus contains the following value :
C:\Windows\Installer\{91140000-0011-0000-0000-0000000FF1CE}\wordicon.exe,13

See this article for more info about Office GUIDs:
Description of the numbering scheme for product code GUIDs in Office 2010.

In any case, FileTypesMan finds this value in the registry. For Word 2010 this value is at :
HKEY_CLASSES_ROOT\Word.Document.12\DefaultIcon.
Copy it from someone who has the same version of Office, or let us know your exact version so we can help.

A problem might arrive if you had another version of Office installed before, or two versions side by side, so some confusion has occurred.

I would suggest first, if you have two versions of Office installed, to uninstall the one you don't need.

Second, try to repair your version by going to Control Panel, right-click Microsoft Office, choosing Repair, Repair again, then Continue.

If this doesn't work, I suggest uninstalling Office and reinstalling. Ensure first that you have at hand the Office serial number (if you can't find it, there are programs that can do it for you).

If you don't have the Office installation media, you could try to reinstall/repair it from the MSOCache folder (ensure hidden files/folders are visible). See the article Install Office 2010 from local installation source.

You can also download a copy of the Office installation media from Microsoft Office 2010 Backup (Office serial number required).

share|improve this answer
1  
I cant copy it from someone else, but I have 2010 Professional edition I believe –  leaf68 Nov 25 '12 at 6:37
    
Which value do you have for default icon? –  harrymc Nov 25 '12 at 8:08
    
C:\Windows\Installer\{91140000-0011-0000-0000-0000000FF1CE}\wordicon.exe,13... which, I checked and it does not exist –  leaf68 Nov 26 '12 at 2:43
    
You seem to have had another version of Office installed before, or some other confusion has occurred. See my edit above. –  harrymc Nov 26 '12 at 6:59
    
I only have 1 version of office installed. I tried re[airing it, but a window opens, and closes 5 seconds later. I tried downloading the installer online (I have a download link instead of a CD) but it has the same problem. –  leaf68 Nov 26 '12 at 22:03
show 1 more comment

I had the same problem, under Windows 7, 32-bit, Office 2010, with missing Excel and Word icons (and I do not recall whether there was anything else missing). I was looking for something to try with the least possible risk. I was wary of using the method involving

DEL IconCache.db /a

(which was generally well received) since I read a couple of posts stating that, in addition to not fixing the problem, it ruined many other icons.

I found a very simple solution as a side effect of other operation. It is possible that this leads to a general solution, although I did not experiment any further after having my problem solved. It is probably worth trying.

I logged off from my user, logged in as admin, and changed the system font size via registry editing to a "non-standard" size (after reading several links). I needed to do it via registry editing instead of doing it from the control panel for specific reasons (irrelevant here). When I logged in again with my user, besides the intended effect, I had recovered my lost icons.

So, I propose trying a change in system font size as a solution. This appears to induce rereading of icons as well, and perhaps refreshing the icon cache as other methods propose. I do not know if the good icons will remain after reverting to the original font size, if that is what you want. One may try doing this from the control panel, to avoid regedit. I guess your mileage may vary.

Good luck.

PS: I am adding two related links here (cannot post more, I have posted others in threads referred to below).

http://answers.microsoft.com/en-us/office/forum/office_2007-word/excel-and-word-icons-dont-display-correctly/fdc46a1a-eb48-4623-8665-73010c539c9e?msgId=a603b89f-d84e-4421-a6aa-2b9743ddbcbe

http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/office-icons-dissapear-in-windows-7/525e9303-86a9-4206-a375-ad81328f408e

share|improve this answer
    
Please provide a more detailed solution, preferably step-by-step instructions. Links die sometimes. –  gronostaj Aug 14 '13 at 13:49
add comment

two suggestions from another site (the first worked for me - I had orange rectangles instead of the big blue W & E) Use Open With & link it to the Microsoft Office Client Virtualization Handler and it worked. Everything is back as it was.

Second idea:

If you're using Starter and can't find winwordc.exe, and also don't have an active link to Word Starter or Excel Starter on the desktop, right-click on the desktop and create new shortcuts with the following paths:

For Word: "C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft Word Starter 2010 9014006604090000

For Excel: "C:\Program Files (x86)\Common Files\microsoft shared\Virtualization Handler\CVH.EXE" "Microsoft Excel Starter 2010 9014006604090000"

Then right-click on the file you want to associate, and Open With > Choose Default Program. Select one of those new desktop shortcuts and it should be linked up again.

share|improve this answer
add comment

Just type "winword /r" in your search box or run, and your problem will be solved immediately. Don't waste time to change IconCache.db because it often doesn't work.

share|improve this answer
add comment

I had a variation of this problem, where the Word icon in the task bar reverted to the default, but files in Explorer still appeared normally.

In this case, deleting the icon cache or repairing Office did not help. Instead, I unpinned Word, created a new shortcut to C:\Program Files (x86)\Microsoft Office\Office15\WINWORD.EXE (your path may vary) in my start menu, launched that, and pinned that to the task bar. This just took a minute, so feel free to try it before reinstalling Office.

share|improve this answer
add comment

Go to Add or [Remove Programs] or other name under different version of Windows, in stead of click Uninstall, click [Change], then repair the installation.

share|improve this answer
2  
could you elaborate your answer what need to be repaired,the user can see lot of programs there –  BlueBerry - vignesh4303 Aug 28 '13 at 4:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.