Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While Fast start-up is enabled, on turning the computer off (shutdown) the computer idles for about 5min after logging out/screen turning off. It then turns off. On returning into Windows I receive the error message saying Windows didn't shut down properly.

Hibernate works fine, and I am told this shouldn't be the case - If one doesn't work, neither should. It works when both Fast start-up is enabled and disabled, as does restart and sleep.

Windows is installed under UEFI.

The UEFI ultra fast boot option for my motherboard cannot be enabled as my GPU doesn't support some UEFI GOP tech. As far as I know, not related to windows fast start-up, but thought it was worth mentioning.

To clarify, if this: http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html is enabled, the computer does not shut down properly.

EDIT: Some more information on the matter:

Formatting didn't fix the issue. Still fails regardless of drivers installed.

Hardware was purchased ~6months ago. Running a good SSD.


Event viewer

Always these two messages in close succession:

Error (event ID 6008): The previous system shutdown at 7:45:21 PM on ‎27/‎10/‎2012 was unexpected.

Critical (kernel power, event ID 41): The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

Update

Upon installing WPT as suggested below to figure out what was happening during shutdown, and running the cmd

xbootmgr -trace shutdown -noPrepReboot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

Windows fast start-up is now working consistently. Still works upon uninstalling WPT. This is the only change to occur on the computer. Nothing else has bee installed/uninstalled, no Windows Updates, nothing. Windows fast start-up did not work prior to installing WPT and running the cmd (made sure I tested).

Update 2

Since a random patch to Windows Defender, computer has again been failing to shut down properly. The above "fix" didn't work this time around.

Update 3

Latest update to Windows Defender has fast stat-up working again.

Update 4

Computer shutting down properly is now completely inconsistent.

share|improve this question
    
Is Windows 8 fully patched ? –  harrymc Nov 19 '12 at 15:05
    
@harrymc yes. Windows updates, drivers, or flashing motherboard BIOS/UEFI with very recent version hasn't fixed the issue. –  user168330 Nov 20 '12 at 0:55
    
You said you formatted the disk and reinstalled Windows. Did the problem exist with a vanilla Windows 8? Or with all possible devices disconnected? –  harrymc Nov 20 '12 at 7:54
    
@harrymc correct, and I literally have no devices plugged into my machine except mouse and keyboard. Don't forget - Hibernate works fine, which I've been told shouldn't be the case... –  user168330 Nov 20 '12 at 10:01
add comment

3 Answers 3

Use xbootmgr from the WPT to trace which the shutdown is slow:

http://www.msfn.org/board/topic/158252-trace-why-windows-8-boots-shutsdown-or-hibernate-slowly/

Generate the Shutdown and Hibernate XML and look what takes so much time.

share|improve this answer
    
I ran it. Upon executing the command, the computer near instantly threw up the restarting screen and restarted (instead of shutting down). I feel it's not an issue of something taking too long during shutdown, but something being too fast, beating windows. –  user168330 Nov 21 '12 at 1:24
    
fast start-up wasn't working just prior to looking at your post. Since installing WPT and running that shutdown cmd, I tried re enabling fast start-up again, and the computer shutdown/started up fine. Will do it a few more times today and see what the results are. bizarre. –  user168330 Nov 21 '12 at 1:31
    
Computer consistently shutting down normally with fast start-up enabled now. Uninstalled WPT, still working fine. That's the only change that's occurred. –  user168330 Nov 21 '12 at 4:44
    
I have no idea why this is so. Be happy that it works now. Btw you used the wrong command. To trace fast boot you must use the fast boot command which I've posted at the end of the guide. –  magicandre1981 Nov 21 '12 at 9:39
    
Ah missed that sorry. I'll see how reliable this 'fix' holds over the next couple of days. Thanks for your help though! –  user168330 Nov 21 '12 at 9:45
add comment

According to Tweaking with Vishal

You can try to execute following command in Command Prompt. Open Command Prompt as Administrator by right-click on the bottom-left corner and select the same option from the Win+X menu:

bcdedit /set disabledynamictick yes

The above mentioned command used to fix a very annoying freezing issue found in Windows 8 Release Preview build. According to Microsoft the issue was fixed in Windows 8 RTM but if you are still facing the issue, you can try the command.

Source: http://www.askvg.com/fix-windows-8-restart-and-shutdown-problems-by-disabling-hybrid-shutdown-feature/

share|improve this answer
    
What does this command actually do? I wish I could test it out, unfortunately the problem disappeared after I installed and ran WPT (see bounty'ed answer)... –  user168330 Dec 6 '12 at 1:56
    
Thanks for that. Please see article above. –  Simon Dec 6 '12 at 9:33
    
Doesn't explain the command, unless it's the same as disabling fast start-up in the power options? –  user168330 Dec 6 '12 at 10:24
    
I guess it is an alternative if the other method that you used didnt work. As long as you have now resolved it.... –  Simon Dec 6 '12 at 10:43
add comment
up vote 0 down vote accepted

Looks to be an issue surrounding Windows Update... Ensuring there are no updates waiting to be downloaded/installed at point of shutdown, I haven't had a problem. This is the closest I've come to 'solving' the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.