Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My PC OS is Windows 8 Pro x64. Windows 8 seems confusing.

D:\ drive is supposed to be used solely by a single user, who is in Users group of the PC. The requirement is...

  • that user will have full control of D drive.
  • Admins will have full control of D drive.
  • All other users can only list drive contents. No file could be opened.

My account is admin account. From D drive's property > Security tab, I've set the following:

  • Allow "List folder contents" for Authenticated Users group.
  • Allow "Full control" for SYSTEM.
  • Allow "Full control" to specific user, who's supposed to use the drive.
  • Allow "Full control" for Administrators group of the computer.
  • Allow "List folder contents" for Users group.

After setting this up, the specific user have full control of D drive. No other user can open any file on D drive.

But though my account is an admin account, no file on D drive could be opened from my account! Why is this happening and how files can be opened from my account?

Note: All accounts in this PC are local accounts.

share|improve this question
Did you tried to take ownership of the drive or not? – avirk Nov 15 '12 at 15:10
@avirk: I changed the ownership of the drive to Administrators. – Donotalo Nov 15 '12 at 17:30
And still have the problem? – avirk Nov 15 '12 at 17:30
@avirk: The ownership was changed before posting here. Cory Smith's technique works! I wonder I the same can be performed by File Explorer. – Donotalo Nov 15 '12 at 17:32
May be right click on "File Explorer" and choose run as admin. Or use ctrl+shift+winkey+number here number refer to the position of the "File explorer" at the taskbar. – avirk Nov 15 '12 at 17:41
up vote 1 down vote accepted

I would guess that it is related to UAC. Even though your account is in the Administrators group, you may need elevated privileges to use the permissions required to open the folders.

You can get around this by navigating through D: in an elevated command prompt by using keyboard shortcut (Win + X + A).

share|improve this answer
Unbelievable! It works! How can I do the same with File Explorer? – Donotalo Nov 15 '12 at 17:31
In Windows 7 you could open explorer with elevated priviledges by holding Shift+CTRL and clicking on the explorer icon. This doesnt appear to workin in Windows 8... – Cory Smith Nov 15 '12 at 17:45

As per comment.....

@avirk: Do you know how to always run File Explorer in admin mode? By the way, right clicking on File Explorer doesn't show any option for running it as admin.

Write the command on notepad C:\>runas /user:username\Administrator "explorer.exe" and save it with .bat extension and run it. It will open the explorer as admin, it will prompt you for password of the admin if you have set any, provide it and you done.

One more way is go to c:\windows and find the explorer.exe and now make its shortcut to the desktop by right click and Send to>Desktop, now right click on the shortcut created on desktop and select the properties and select Advanced and now mark the Run as admin option and click OK and then "Apply".

share|improve this answer
Windows 8 is still confusing! I thought your method will work, but it didn't. I'm not sure why. Finally, I granted full control of D drive for my user account. Only then it worked even I didn't need to open File Explorer in admin mode. – Donotalo Nov 16 '12 at 15:08
This trick works on at least few other software like uTorrent, DirSyncPro and NFS most wanted. But doesn't work with File Explorer! – Donotalo Nov 16 '12 at 18:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .