Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had Debian 6 on my machine (Dell Vostro 260) and used GParted to shrink the partition. I then tried installing Windows 7 on that partition. After Windows 7 installed, I could not choose which OS to run. It would just boot into Windows.

I ran GParted again, and saw that Windows created another partition, labeled "System Reserved". That partition had the boot flag set. I tried moving the boot flag to other partitions, including my Debian partition and one with a file system "linux-swap". No option would actually load an OS or anything except for the Windows partition, which is not what I want.

Is it worth it to try to fix this installation, or should I start over. I have all my data backed up, so I can easily install from scratch if I need to. If I do start from scratch, which OS should I install first? And then, how do I set up the partitions to install the other OS?

Let me know if you have any questions. Thanks for your help.

share|improve this question
up vote 2 down vote accepted

It happens because Windows overwites any boot loader it finds.

To make it simple, you should just reinstall your bootloader.

Boot Debian installation DVD and find any option to repair the system. If Debian has a graphical tool like Suse's YaST, it will detect the bootloader is corrupted. It will then create a new bootloader with Windows option too.

There you will have bootloader again. No need to format.

For the next time, install Windows first...

share|improve this answer
Thanks for the info. There was an option to reinstall GRUB on the Debian CD. But it failed to install. So I'm going to reinstall Windows first, then Debian. – Jeremy Nov 15 '12 at 17:11
You should try to understand why it failed. If your laptop is running UEFI I suggest Efililo bootloader. Other things don't currently come into my mind – usr-local-ΕΨΗΕΛΩΝ Nov 15 '12 at 17:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .