Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a closed source software (client) running on a Linux machine (Debian) to deliver files to a backup machine.

This works fine except this client software does not access the mounted volumes (either NFS or SMB). So far I don't know why, as the rights are pretty open to those folders and any other user can access it...

Anyway, this client can access/send other folders and files, so would there be a way to make the mounted volumes appear to that client as "normal folders"?

share|improve this question
1  
I am curious if you could symlink them and point the client to the symlinks? ln -s /path/to/hdd /path/to/new/symlink Or maybe make a custom script that scrubs the folders to a tmp local folder, backs it up, and deletes...? (although that creates a lot of overhead) –  nerdwaller Nov 15 '12 at 17:38

1 Answer 1

up vote 0 down vote accepted

This is one of those "I'd need to be there with you debugging it" sort of problems, especially since you haven't said which proprietary client you're using.

The answer to your question as asked is "yes and no"; if your NFS mount is /nfs/, and a program interacts with /nfs/foo, that's a normal file as far as that program can tell, period. Unless it asks. If it actually specifically asks the OS "What sort of filesystem is /nfs/foo a part of?", it'll get told that it's NFS. You can't change either of these things, basically; in particular, you can't get the OS to tell the client that the NFS mount isn't an NFS mount, at least as far as I know.

However, it's very unlikely that the client is actually asking.

Here's what I'd check:

  1. The most likely issue is that the client is running against / (the root file system) and is refusing to cross file system boundaries; that's fairly typical. Again, you can't fix that directly, but what you can probably do is give it other places to look. Try adding your NFS or SMB shares to the client as backup locations explicitly.
  2. NFS at least (and I think SMB) by default prevents root on a client host from doing a lot of things; if #1 doesn't work, try adding no_root_squash to your NFS exports (make sure it worked by running "exportfs -v" on the master and looking for the option) and see if that helps.
  3. If those both fail, I would strace the client (using -ff -o /tmp/strace.out or so) and grep for one of the filesystems it's not picking up, and see what errors it's getting, or if it's even trying. If it's not even trying and you've explicitly listed that FS as something to backup, you'd best talk to the vendor.

-Robin

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.