Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Seagate 500 GB USB hard drives. I installed Debian 2.6.32-5-686 on one of them, and used dd to create a clone of the bootable drive. I have verified that I can boot and run from either drive. The format I used was ext3.

I would like to boot from one of them, and mount the other on a second USB port. But I can't figure out how to get the 2nd drive to mount.

Here's what fdisk returns for my system:

root@debian:/media# fdisk -l

Disk /dev/sda: 256 MB, 256901120 bytes
16 heads, 32 sectors/track, 980 cylinders
Units = cylinders of 512 * 512 = 262144 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x727232e1

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         979      250608    b  W95 FAT32

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009afe2

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       60046   482318336   83  Linux
/dev/sdb2           60047       60802     6065153    5  Extended
/dev/sdb5           60047       60802     6065152   82  Linux swap / Solaris

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009afe2

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           1       60046   482318336   83  Linux
/dev/sdc2           60047       60802     6065153    5  Extended
/dev/sdc5           60047       60802     6065152   82  Linux swap / Solaris

========================================

sda is a CF card (also bootable; I have DSL installed on it).

I created a subdirectory in mnt (debian 2) and tried to mount sdc:

root@debian:/media# mount -t auto -o uid=howard,gid=users /dev/sdc debian2
mount: you must specify the filesystem type

Ok, since I know that the filesytem is ext3, I tried that:

root@debian:/media# mount -t ext3 -o uid=howard,gid=users /dev/sdc debian2
mount: wrong fs type, bad option, bad superblock on /dev/sdc,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
root@debian:/media# dmesg | tail
[ 3574.656384]  sdc: sdc1 sdc2 < sdc5 >
[ 3574.755489] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[ 3574.755501] sd 6:0:0:0: [sdc] Attached SCSI disk
[ 4357.910378] VFS: Can't find ext3 filesystem on dev sdc.
[ 4398.311616] VFS: Can't find an ext2 filesystem on dev sdc.
[ 7765.840482] [drm] Big FIFO is disabled
[ 7766.124349] [drm] Big FIFO is disabled
[ 8490.172175] [drm] Big FIFO is disabled
[ 8490.172718] [drm] Big FIFO is disabled
[13344.805443] VFS: Can't find ext3 filesystem on dev sdc.

testdisk can see it:

Disk /dev/sdc - 500 GB / 465 GiB - CHS 60801 255 63
Current partition structure:
     Partition                  Start        End    Size in sectors

 1 * Linux                    0  32 33 60045 250 45  964636672
 2 E extended             60046  28 13 60801  47 46   12130306
 5 L Linux Swap           60046  28 15 60801  47 46   12130304

When I went to analyze, I got this: EXT3 Large file Sparse superblock, 493 GB / 459 GiB

I have the same results regardless of which one I boot from (physically swapping & rebooting).

There should be a clue about what I'm doing wrong somewhere in there. I'm guessing (hoping) it's a n00bie mistake that's easy to fix.

TIA for any insight.

share|improve this question
1  
you cant mount /dev/sdc this would be the whole disk. try mounting /dev/sdc1 instead. –  l1zard Nov 15 '12 at 18:05
add comment

2 Answers

up vote 0 down vote accepted

To mount the disk, you need to specify a partition #.

So for you it looks like it would be /dev/sdc1, the system figures out most of the rest by default. So all you should need to type is:

mount /dev/sdc1 /media/debian2

If you want that to happen on boot, you could add the drive to /etc/fstab.

share|improve this answer
    
Thank you. That worked. –  Howard Lee Harkness Nov 15 '12 at 18:58
    
@HowardLeeHarkness Great! Please be sure to accept an answer so people searching a similar issue in the future know it's been answered (whether that's mine or else isn't as huge a deal). –  nerdwaller Nov 16 '12 at 1:02
add comment

You must mount /dev/sdc1. Also ensure that you have created the mountpoint where you want to access the disk.

the usual procedure in your case is:

mkdir /media/extern; mount /dev/sdc1 /media/extern

In Linux sdX stands for the actual hardrive and sdX1, sdX2, sdX3, ... and so on represent the actual partitions.

when it comes to physical harddrives linux does not allow you to mount a complete disk. you always mount partitions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.