Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a crossover cable to connect two computers. Despite having Gigabit LAN, they only provide me with 100 Mbps networking.

My question is whether is it possible to get 1000 Mbps networking using a crossover cable? If so, how?

share|improve this question
    
See my updated answer. Your cable is wired incorrectly and doesn't map Ethernet signal pairs to physical wire pairs as required by the standard. (This is required for 100Mbps too, but higher speeds and longer cables are much less forgiving.) –  David Schwartz Nov 19 '12 at 0:21

5 Answers 5

up vote 6 down vote accepted

Don't ever use a crossover cable to connect a Gigabit device to anything unless you have some very specific and incredibly unusual reason to do so. Just use a straight through cable. Crossover cables and Gigabit NICs don't mix.

2001 was a long time ago. Modern network interfaces have auto-MDIX and don't need crossover cables. Gigabit speeds and crossover cables don't mix because Gigabit combines transmit and receive functions on the same wires.

Newer routers, hubs and switches (including some 10/100, and all 1 Gigabit or 10 Gigabit devices in practice) use auto-MDIX to automatically switch to the proper configuration once a cable is connected. The other four wires are used but are not crossed since auto-MDIX is mandatory at the higher data rates (1000BASE-T transmits and receives on all pairs simultaneously without any dedicated send/transmit pairs).

Update: Your wiring pattern is incorrect. You have A+ and A- on the blue pair and D+ and D- on the brown pair, which is fine. But you have B+ and C+ on the orange pair and C- and B- on the green pair. You have to match Ethernet signal pairs to physical wire pairs.

share|improve this answer
1  
"Don't ever use a crossover cable", "Crossover cables and Gigabit NICs don't mix." - Please can you elaborate on this? –  Bryan Nov 16 '12 at 0:23
    
He's right. You don't need a crossover cable. Modern NIC's work this out automatically. –  Matt H Nov 16 '12 at 0:26
1  
Hubs don't exist anymore. When Gigabit was developed, it was already accepted that Ethernet would be point-to-point and full duplex. To get the bandwidth they needed, Gigabit abandoned the idea of using only dedicated wires for each direction and started sharing them. The notion of swapping transmit and receive wires makes no sense when the same wires are used in both directions anyway. –  David Schwartz Nov 16 '12 at 0:26
    
@ekaj: What model are they? –  David Schwartz Nov 16 '12 at 0:27
    
Going to a straight through cable should give gigabit link speed. –  Matt H Nov 16 '12 at 0:27

The specific answer is YES, just use the appropriate cable and networking equipment.

share|improve this answer
    
To whoever downvoted that: The appropriate cable probably is the right answer. –  Hennes Nov 15 '12 at 23:00
1  
@Hennes - This answer could easily have been a comment it doesn't even go into technical detail. –  Ramhound Nov 16 '12 at 1:29
    
I agree, but I also think that a comment for a relative new user (300ish rep) might help them. Especially if I miss the reason why after being on this site for a year. And I knew those comments helped me when I was new. –  Hennes Nov 16 '12 at 7:14
    
@Hennes - I downvoted, not because the answer is wrong, but because I didn't think it was a good answer. "The appropriate cable and networking equipment" isn't going to help kashif fix his problem. Of course, if the answer is improved, I'll reverse my vote. –  Bryan Nov 16 '12 at 10:43
    
I agree that is was a poor answer. I am just trying to be constructive here. (Heck, even my own answer is damn brief). –  Hennes Nov 16 '12 at 10:45

If the networks falls back to 100 mbit then you either

  1. Used a wrong cable. (You need a straight cat5E, cat6 or better cable for gigabit).
  2. or manually selected that speed on one of the computers.
share|improve this answer
    
I tried Straight through cable in my m2n-e and xfx 750i motherboard to get 1000mbps but got the strange error. in xfx750 using windows8 I got network connection disabled and in m2n-e using windows7 I got limited 10mbps connectivity. while the lights of both NICs were abnormally yellow instead of green –  kashif Nov 16 '12 at 12:57
    
Weird. I only had something similar once. That was when my drivers where not working correctly with a then brand new 3c905B cyclone NIC. Ifconfig showed 'no link' but I could telnet out and transfer up to 3kb/sec. Anyways, potential driver problems. Can you check if you get the latest win7 driver on win7, or what happens if you boot a liveCD with a different OS. –  Hennes Nov 16 '12 at 16:18
    
installing the drivers im getting 100mbps. But useless. I don't know why. Im not able to ping one computer through another. even I'm not able to ping one computer from the same as it happens when network is unplugged... –  kashif Nov 17 '12 at 21:24
    
@kashif: Don't test with ping until you confirm IP address assignments and routing is correct. Go one step at a time checking each thing before moving on to the next. –  David Schwartz Nov 18 '12 at 0:30
    
well! I've been atleast able to get 100mbps using straight through cable in two pcs both having gigabit lan that I have earlier were strugling for i.e I was even not able to get 100mbps connection. now My problem is to get 1000mbps. I have installed the correct lan card driver in both the pcs –  kashif Nov 18 '12 at 11:44

You should be able to so long as you are using Cat5E or better (Cat6, Cat7) cable. A switch shouldn't be necessary for only two computers. If you are using Cat5E or better cable, make sure both NIC's are gigabit and both NIC's are set to 1000Mbps/Full Duplex. It's possible Autonegotiation might be getting messed up in the process. In Windows this is done under the properties for the NIC itself (you can get there from Device Manager)...not sure where it is in other OS's.

share|improve this answer
    
Both ends MUST be set to autonegotiate for gigabit to work. It only caused problems in 10/100 because autoneg was never defined in the specs and was implemented slightly different by everyone. –  Sammitch Nov 15 '12 at 23:16
    
If you have a configuration where 1000/Full is not being autonegotiated, forcing it will almost certainly result in the connection not working at all. About the only way to cause 1000/Full to not be autonegotiated when autonegotiation is enabled is to prevent it from working at all (say by using incorrect cables). –  David Schwartz Nov 16 '12 at 0:28

Gigabit does not work with crossover cables. This is because of how gigabit uses the pins differently to 10/100. Use a straight through cable!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.