Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run emacs with -nw option, the emacs really open, but I can't do more nothing. As if the user input is blocked and no keyboard signal is received and/or interpreted. I've tried run without load .emacs file and some other behaviors:

emacs -nw -Q --no-desktop --debug-ini foo.c

But makes no difference and strangely the GUI-version(using Gtk) is working fine.

My gnu-emacs version is GNU Emacs 23.3.1

Any help to help to fix it is very appreciated.

share|improve this question

migrated from stackoverflow.com Nov 16 '12 at 11:10

This question came from our site for professional and enthusiast programmers.

    
What shell are you running it in and what terminal emulator? –  Jesus Ramos Nov 16 '12 at 3:41
    
I have tried by using konsole and xterm. –  Jack Nov 16 '12 at 3:42
    
Check that your terminal isn't grabbing input (such as Ctrl and Alt keys from you) –  Jesus Ramos Nov 16 '12 at 3:43
    
not.. the xemacs is working fine xemacs -nw foo.c –  Jack Nov 16 '12 at 3:48
    
Off-topic, but I would try running strace -p on emacs' pid to see if you can determine where it's stuck (or starting emacs with strace -o logfile.txt emacs -nw). –  R.. Nov 16 '12 at 4:26
show 3 more comments

2 Answers

Do you have a ~/.emacs config file that might be hanging Emacs and not Xemacs?

Is your env variable $TERM set? Have you reconfigured any of your terminal settings (maybe using 'tset', like ROWS or COLS)? Does 'reset' help?

It sounds like other apps that use vt100 emulation and curses are OK (e.g. Xemacs). I assume vi works normally?

share|improve this answer
    
1) not. 2)yeah, it's defined with xterm value. 3)tset and reset didn't difference. 4)hmm not sure if vt100 how do I check? and yeah, the vi is working fine. –  Jack Nov 22 '12 at 18:00
add comment
up vote 0 down vote accepted

I couldn’t find the error. I just updated emacs to 24.2.1 and it works fine now.

share|improve this answer
    
@Synetech: Thanks for the correction. English isn't my native language speaker. –  Jack Nov 23 '12 at 13:21
1  
No problem, that’s why we are allowed to edit. ☺ –  Synetech Nov 23 '12 at 16:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.