Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've noticed an interesting problem recently where my laptop will not automatically refresh my DHCP lease when changing between wireless networks. Instead, it will attempt to use the existing lease for the new network. Of course, since each network has different settings any connections will fail when using the old lease.

While Windows will eventually request a new DHCP lease, it's often much faster for me to release the old lease and request a new, correct, lease. It puzzles me as to why this is not automatically done when associating to the network? One possible cause is that the laptop is put to sleep while connected to one network, then woken when in range of the other network. Nevertheless, I would expect that the lease would be renewed when the laptop associates to the other network rather than attempting to use the old lease.

It should be noted that the two networks are completely different, both in terms of size, number of APs, network settings, SSIDs etc. One network is my home network and the other one is the campus-wide network at my University.

share|improve this question
1  
What version of Windows? What brand and model of laptop? –  CharlieRB Nov 16 '12 at 14:05
    
A few questions: 1) Is it just the DHCP server at the university or all WiFi? 2) Does it do the same thing if you try the wired network at the University? 3) Is your computer joined to the Windows Domain at the University? –  JamesBarnett Nov 24 '12 at 8:55
    
@CharlieRB Windows 7 Professional x64. Laptop is a Samsung RF711, however the wireless card has been upgraded from the default card to an Intel Centrino Advanced-N 6235. I have ensured that the latest drivers have been installed from Intel's site. –  KingJ Nov 30 '12 at 15:15
    
@JamesBarnett 1) I've only noticed this on the University's network. 2) Trying to replicate this on the wired network would be difficult, there are very few user-accessible wired connections. 3) It is not joined to the university's windows domain. –  KingJ Nov 30 '12 at 15:16
add comment

3 Answers

I have some similar problem when trying to connect wireless on my home network and in office, I can't connect automatically on office if have previously connected to home network, so solved like this:

You have to include options to "Connect automatic when is in the range" at your wireless network, problem in your connection can appear cause you didn't use connect when is in range instead you use only "Connect automatic" to some network.

If problem still appear than check if some of your network have enable options "Automatical connet" and other don't have, well in that case you have to put all wireless network on automatic connect or disable all automatic connections and connect manually in meter where you are.

Sorry at now i don't have installed wireless to show you exact steps.

UPDATE:

Sometimes when you use static ip and want to connect to dynamic it wan't automatically renew address, so this script will help you to renew address (use your information)

 netsh interface ip set dns "Wireless connection" dhcp
 netsh interface ip set address "Wireless connection" dhcp

Well in the case that you want connect in reverse order use this script

netsh interface ip set address "Wireless connection" source=static addr = 192.168.1.22 mask = 255.255.255.0 gateway = 192.168.1.1 gwmetric = 0
netsh interface ip set dns name = "Wireless connection" source = static addr = 212.191.128.55
netsh interface ip add dns name = "Wireless connection" addr = 212.191.128.56

If you are still have problem try to delete all previous configuration and do it on more time.

If there is still problem than you miss something crucial at configuring network.

share|improve this answer
    
The connection is established automatically, however the DHCP lease is not renewed - it attempts to use the previous lease from my home, or other, network. The "Connect automatically when the network is in range" option is set. –  KingJ Nov 30 '12 at 15:20
    
see update on question –  tonni Nov 30 '12 at 17:29
add comment
up vote 0 down vote accepted

I'm going to conclude that this is due to an minor incompatibility between my equipment and the university's managed wireless system. My reasoning behind this is;

  • I usually experience this issue when using my laptop with the university's wireless system. My laptop connects normally to other wireless systems and my Android devices also seem to connect to the university's wireless without issue.
  • The wireless system uses eduroam - which requires WPA2 Enterprise authentication using my university credentials against the university's authentication service. There have been many complaints from other students about slow authentications, especially during peak times. Perhaps my laptop attempts to renew it's lease before it has fully authenticated.

Unfortunately, it is difficult to confirm these reasons however I strongly suspect that this is the case based upon many months of usage.

share|improve this answer
add comment

I know this is a late response, but I recently observed a similar issue in Windows 7 x64 when connecting with a Centrino wireless chipset to wireless networks served by Android. This fix worked for this particular case:

Network and Sharing Center >
Change adapter settings > 
(right-click) Wireless Network Connection Properties > 
Internet Protocol Version 4 Properties > 
Advanced > 
Append primary and connection specific DNS suffixes (select radio button)

I had specific DNS suffixes listed, and it seems this was causing trouble.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.