Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The situation - At my girlfriend's parents' place there are six Windows 7 devices that are wired or wireless connected to a router: 3 dekstops and 3 laptops. There are also several smartphones using the router. The router is secured with WPA2 (AES).

The problem - We never had any problems with the router for over a year. But recently - about 3 weeks ago - my girlfriend's laptop (HP) and my laptop (ASUS) started to develop problems while trying to connect to the router. The router has stopped showing up from the network list. Sometimes it comes back and shows up, but then it keeps saying something along the lines of "Could not connect", and not long after that it dissapears again.

The range of the router is not the problem here, because we experience the same when we sit next to the router. Sometimes, if we are lucky, and waited a long time (10-15 minutes) without using the laptop for anything, the laptop will eventually succesful connect to the router.

The attempts - Of course, the Window 7 troubleshooter. We tried troubleshooting the connection problems and the wireless network adapter, but no luck. We also reset the router enough times to know that's not helping either. Here's the full list of things we tried, but did not help:

  • Running the Windows 7 troubleshooter
  • Resetting the router (more than once)
  • Setting the router settings to factory defaults
  • Disconnecting all other devices except one laptop
  • Applying a system restore
  • Trying static/dynamic IP/DNS - Dynamic is better, right?
  • Enabling/disabling IPv6 - Should I keep IPv6 disabled?
  • Running the command: netsh wlan stop hostednetwork
  • Running the command: netsh wlan set hostednetwork mode=disallow
  • Updating/reïnstalling wireless adapter drivers

The tests - To help finding the core of the problem, we tested the following:

  • Plugging an ethernet cable in the router and in our laptops - worked fine
  • Connecting someone else's laptop to the router (wireless) - worked fine
  • Connecting our laptops to someone else's router - worked fine

The router - This information might be relevant:

  • Router model: Sitecom 300N Wireless Router
  • Router hardware: version 01

The DCHP Server's IPs range from to Router settings:

  • Wireless channel: 12
  • Channel bandwidth: 20/40 MHz
  • Extension channel: 8
  • Preamble type: Long
  • 802.11g protection: Disabled
  • UPnP: Enabled

The laptops - If you are wondering about our laptops:

  • My laptop model: ASUS Pro64JQ
  • Girlfriend's laptop: HP Pavillion G6
  • OS: Both Windows 7 Professional x64 - with Service Pack 1
  • My wireless adapter: Atheros AR9285
  • AdHoc 11n: Enabled

The question - Does anyone have experienced the same problems as I do? Or does someone know how to solve this? Are there more tricks I can try, or settings I should change?

Note - Our laptops are not slow or old. My laptop is 1.5 years old, and the other laptop is just 5 months old. I know how to keep laptops clean and I'm pretty sure both laptops are not bloated with useless software.

share|improve this question
What channel is the router on? – David Schwartz Nov 17 '12 at 0:21
@DavidSchwartz - The router is on channel 12. It's extension channel, don't know what that is, is on 8. If you want to know more, see the edit I made to my post. – Ruud Lenders Nov 17 '12 at 13:57
up vote 0 down vote accepted

Okay, this might sound weird, but I fixed by doing things I've tried before. I don't really know what fixed it in the end, but it's fixed. :)

To the people who are interested, this is what I did (probably):

I removed and reïnstalled the drivers again, but this time a different version. However I installed the latest version right after that. In the meanwhile I reset the router to factory defaults, and disabled my LAN Ethernet Adapter. I've disabled/enabled my WiFi adapter a couple of times, and restarted my laptop for about twice. Somehow this removed all saved wireless networks from my laptop, and now I have to fill in every WEP/AES key again. That sucks, because I use my laptop at a lot of places, but now it works again. :)

Edit: After I fixed the issues with my laptop, the issues with my girlfriend's laptop were gone too. So it was probably resetting the router to factory defaults that did it. It wasn't the first time I tried that, but maybe I did it wrong earlier.

share|improve this answer

Did the router reset change your channel bandwidth setting from 20/40 to 20 only? I found changing to 20 only fixed a couple of constantly dropped connections for me, improved speed too, despite logic dictating otherwise. There's plenty of articles describing why 20/40 isn't generally a good idea.

share|improve this answer

Try changing the channel on the router. If it's on Auto, try something like 3 or 8. Channels 1, 6, and 11 are the most commonly used so it's better to distance yourself from those.

Another settings on some routers is the channel width. Sometimes you'll see 10 MHz, 20 MHz, or 40 MHz. The higher the setting, the faster the throughput but the stronger the signal needs to be to work well.

There are wireless networking tools available also for PC, Mac, and mobile devices that can help you get more info on your wireless "environment" that might help.

If changing the channel doesn't help, it could be overheating. Routers, like computers, will lower their power consumption when they get hot. Other than these things, it's possible that the wireless chip in the router is going bad.

share|improve this answer
So you think it's the router's fault, then? Even though all other devices work just fine? Interesting. I will try changing those settings tomorrow, but I'm sure it's not overheating. – Ruud Lenders Nov 16 '12 at 20:51
About that last paragraf of answer, he wrote that with other notebook it just works, so we can exclude problems like router is overheating... I would try to switch in network card preferences, on that hp, wifi type to G and disable N – week Nov 16 '12 at 20:53
@week - what do you mean by wifi type? How do I set/disable that? – Ruud Lenders Nov 16 '12 at 21:10
On keyboard -> Win + R, and start ncpa.cpl, then select your wifi adapter, mouse right click and select preferences, then select configuration..., than on 2nd tab find something like 802.11n mode or mode n, select and disable it, then accept by ok and try to connect.. – week Nov 16 '12 at 21:17
Whoa! Hugely bad advice about the channels! The channels overlap. If you use channel 3, you overlap both 1 and 6, making things much worse for everyone. When two networks are on the same channel, they can see and avoid each other. If they're on overlapping channels, they can't and step on each other horribly. – David Schwartz Nov 17 '12 at 0:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .