Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Laptop randomly waking up = Hibernate / Low Battery?

My PC wakes up from sleep randomly.

I disabled Hibernation after Sleep.

I am using Asus N53SV with Windows 7 64 bit.

Power Options > Sleep > Allow wake timers are disabled.

It doesn't wake up from Hibernation.

My searches yielded "Look for powercfg lastwake", "Disable wake timers" but they didn't help me.

powercfg lastwake shows this:

Wake History Count - 1

Wake History [0]

Wake Source Count - 0

PowerCfg -DEVICEQUERY wake_armed shows this:

HID Keyboard Device (001)

Which is normal since keyboard should wake up when pressed. The PC wakes up even when the lid is closed, so keyboard is not pressed.

powercfg -energy shows

System Availability Requests:System Required Request

The device or driver has made a request to prevent the system from automatically entering sleep.

Requesting Driver Instance HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_10431063&REV_1001\4&cc8e931&0&0001

Requesting Driver Device Realtek High Definition Audio

I'm using the latest Realtek driver

So what should I try next?

share|improve this question

marked as duplicate by Synetech, ChrisF, soandos, HackToHell, Simon Sheehan Nov 18 '12 at 17:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Sounds like a case of insomnia... – Mehrdad Nov 17 '12 at 8:29
Duplicate of what? – r_alex_hall Feb 24 at 4:24
Some people think it's duplicate of the link below. You can also see this link next to the number of votes.… – formicin Feb 25 at 12:21

The same thing happened to me yesterday. I checked online for a solution and found mention of applying the Visual Studio 2010 update KB2764593 being a solution, but I don’t have VS2010 installed.

I eventually figured out that the problem was caused by a failure of my Intel network adapter. Please check the Windows Update.

share|improve this answer
Thanks, I always download the latest updates. No change yet. – formicin Nov 19 '12 at 7:00

You did not specify what happens when it wakes up (does it stay on or does it turn off after a minute?), but since you mentioned a “lid”, thus implying it is a laptop, combined with the lack of lastwake history, then it probably the same issue that I investigated earlier this year.

If so, then chances are good that it is not really random. What’s probably happening is that the system is switching from sleep mode to hibernation mode after a specific, but long amount of time (e.g., six or 12 hours), and by putting the system to sleep at different times, the switch happens at a seemingly random time.

For example, if the system is set to switch after six hours and you put your system to sleep at 6pm, then it will wake up at midnight. If you then sleep it at 7:45pm the next day, it will wake up at 1:45pm, which looks random, especially in the middle of the night.

This seeming randomness is exacerbated by the fact that the transition timeout period is different for battery and AC power. So even if you always sleep it at about the same time, it can be different (by several hours) if you happen to have it plugged in one day and unplugged the next.

The issue is that by disabling hybrid-sleep, the system is not supposed to switch from standby to hibernation, but that setting does not seem to work and it always wakes up to hibernate.

What you can do is to modify your power-configuration profiles to set the hibernation to be the same as the sleep setting or (not recommended) just disable it altogether. Either way, make sure to change it for all power profiles and modes, that is, for Power Saver, Balanceed, and High Performance (and any others you created) and for each profile, set it for both Battery and Online modes.

share|improve this answer
Thanks for the detailed answer Synetech. I forgot to mention in my question that I disabled hibernation after sleep. I will try the logging method. – formicin Nov 19 '12 at 6:59

Not the answer you're looking for? Browse other questions tagged .