Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use the language bar to switch between Chinese and French keyboards. However lately an English keyboard option also appeared in the popup. I didn't add it myself and I cannot find any way to remove it. For some reasons, it doesn't show up in the Settings page (see screenshot below). Any idea what could be the reason?

enter image description here

enter image description here

Edit

This is what I have in the registry:

HKEY_CURRENT_USER\keyboard layout\Preload
    1    REG_SZ    0000040c
    2    REG_SZ    00000804
    3    REG_SZ    e0200804
    4    REG_SZ    e0210804

HKEY_CURRENT_USER\keyboard layout\Substitutes
    0000040c    REG_SZ    a001040c

HKEY_CURRENT_USER\keyboard layout\Toggle
    Language Hotkey    REG_SZ    1
    Hotkey    REG_SZ    1
    Layout Hotkey    REG_SZ    3
share|improve this question
    
What about adding and removing again? –  week Nov 17 '12 at 10:08
    
@week, thanks for suggestion, however I just tried and it didn't work. When I've added it, the keyboard showed up in the Settings page, however when I removed it, it stayed in the language bar. –  this.lau_ Nov 17 '12 at 10:15
    
Post here what you have in registry under HKCU\Keyboard Layout` in keys preload` and Substitutes. Run cmd.exe and type reg query "hkcu\keyboard layout" /s –  week Nov 17 '12 at 10:39
    
@week, I've posted the registry info, can you see any issue in there? –  this.lau_ Nov 18 '12 at 5:26
add comment

1 Answer

up vote 1 down vote accepted

Yes, there is missing US keyboard. Run this command from cmd.exe or add value below to registry. Then open taskmgr (ctrl + shift + esc), kill process explorer.exe and by "File" -> "New task" start again. Then remove US keyboard, the option will be there.

reg add "hkcu\keyboard layout\Preload" /v 5 /t REG_SZ /d 00000405

HKEY_CURRENT_USER\keyboard layout\Preload 5 REG_SZ 00000405

share|improve this answer
    
Thanks a lot for your help, it worked. –  this.lau_ Nov 20 '12 at 14:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.