Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend of mine had GPT partition n his Lenovo laptop. While formatting the computer and reinstalling the OS, I wiped of all the partitions, and created 4 new partitions. Now after installing everything, when I turned off the laptop. It isn't booting, I checked the BIOS settings, and tried booting Ubuntu off my life disc, it ran well, but again, I can't boot anymore.

Later I figured out, that this is happening because I had deleted the GPT partition, and now the OS has tried to create MBR records, so basically this is the problem.

share|improve this question
1  
Is there a problem with your boot loader? –  superuser Nov 17 '12 at 11:43
    
I don't think so, like I turn on the laptop, and the lenovo logo comes, but after that the computer goes blank I was working on it, found out I have deleted the necessary GPT files and its partition, now when I am reinstalling windows from my bootable disc, as you know it is creating MBR files, and for some reason it is in't working, although while working from my live CD, I can see all the files in the HDD –  Manish Kumar Singh Nov 17 '12 at 12:32

1 Answer 1

There is no such thing as "the GPT partition." I suspect that you mean that you deleted the GPT protective partition, which is a "fake" partition record in the MBR partition table intended to prevent GPT-unaware programs and utilities from messing with the disk. If I'm right in this supposition, you ended up with a disk that has most of its GPT data intact and a legal MBR partition table containing the partitions you intended to create. This is technically a legal MBR setup that shouldn't cause problems, but some utilities do get confused with this sort of a configuration, and it's conceivable that some firmware implementations wouldn't like it, either. The solution in this case, assuming you don't want the GPT partitions, is to erase the stray GPT data. You can use my FixParts program to do this. If you actually want to revert to your old GPT configuration, you might be able to rescue it with my GPT fdisk (gdisk). (The linked-to page includes information on various types of partition recovery operations.)

It's also possible that you used a GPT-aware tool to delete old partitions and create new ones, in which case your partition table is intact but your system isn't booting for some other reason -- perhaps you've installed an OS in BIOS/legacy mode but the firmware is set to boot in EFI mode, for instance. If this is the case (and this might be the case even if my first hypothesis is correct), you'll need to dig into your firmware to locate its boot options and change them.

Unfortunately, the information you've presented is rather inconclusive, so it's hard to be more definitive about this. Detailed information on your partitions and boot loader configuration are required. One way to get this is to download and run the Boot Info Script from a Linux emergency disc (like Parted Magic or System Rescue CD). This will produce a file called RESULTS.txt. Post a link to it here to provide us with more information. It would also be helpful to know what OS(es) you installed on the computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.