Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a new Toshiba s855 notebook with windows 8 preinstalled. Secure boot feature was enabled by default.

I installed latest version of ubuntu after disabling secure boot feature(it was not possible to install ubuntu without disabling secure boot). But now when I enable secure boot, the system automatically boots into windows 8, and it boots into ubuntu when I disable secure boot.

EasyBCD lists the following boot entries but I can only see Windows 8 in boot menu:

Default: Windows 8
Timeout: 7 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Ubuntu
BCD ID: {971641cd-304a-11e2-be82-806e6f6e6963}
Device: \Device\HarddiskVolume2
Bootloader Path: \EFI\ubuntu\grubx64.efi
...
Entry #5
Name: Windows 8
BCD ID: {current}
Drive: C:\
Bootloader Path: \windows\system32\winload.efi

Any recommendations will be appreciated.

share|improve this question
1  
What exactly is your question, or what are you trying to achieve? Dual-boot with Secure Boot disabled? Can't you just add Windows 8 to the Ubuntu bootloader? Or do you want to use the Windows 8 bootloader? There are dozens of guides out there explaining how to achieve dual-boot with Windows and Linux. What have you tried? Where exactly are you getting stuck? –  Indrek Nov 17 '12 at 17:51
    
It's really not that straight forward. But got it working now, nevermind. –  Serkan Özkan Nov 17 '12 at 18:42
    
You should post your solution as an answer, then, for the benefit of others who run into the same problem. –  Indrek Nov 17 '12 at 19:07
    
I disabled secure boot, installed fedora (instead of ubuntu) and let it decide about the partition layout instead of manually editing. Then I added windows to the fedora bootloader and it worked. Then I noticed that neither wireless nor ethernet adapters of the laptop has linux drivers and all that effort was for almost nothing :) –  Serkan Özkan Nov 20 '12 at 12:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.