Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just purchased an Asus Zenbook Prime UX31A-DH51 with Windows 8. I want to wipe the drive and do a clean install but USB is not listed as a boot option in the BIOS. Does this mean it is not possible?

Here is a photo of my BIOS options.

enter image description here

This is the only option I get when I click Add New Boot Option. Not sure if I can add USB here.

enter image description here

* Update * Asus tech emailed and said: "Unfortunately with Windows 8 you can not boot from bios."

share|improve this question
1  
What happens when you click on "Add new boot option", it should give you the option for USB. –  Sane Nov 17 '12 at 23:45
    
I posted a second screen with what happens if I click add. That filesystem option is all I get. Not sure if I can add USB here somehow. –  Chace Fields Nov 17 '12 at 23:50
    
When the system is booting I think you can hit F9 to get to the boot menu, is USB listed there? –  Sane Nov 18 '12 at 0:01
1  
Can you try this? Press Escape to get into the boot menu. If the USB bootable device is not listed, enter the configuration menu and directly press F10 to save. Press Escape again on reboot: This time the USB bootable device should appear in the menu. ( Source: wiki.archlinux.org/index.php/ASUS_Zenbook_Prime_UX31A ) –  Hennes Nov 18 '12 at 0:12
1  
Drat. One more question: Is USB legacy support turned on or off. ( This is mostly needed when emulating older PS/2 keyboards and mice for an OS which does not support USB. E.g. DOS. However it also affects some USB boot options. ) –  Hennes Nov 18 '12 at 17:10

12 Answers 12

I just went through the same pain... but I found a workaround.

  1. Plug in your USB drive
  2. Turn the Zenbook on
  3. Enter UEFI (BIOS) through pressing ESC or F2
  4. In 'Boot' tab: 'Disable Fastboot' (*)
  5. Press F10 to save & exit
  6. Immediately press ESC or F2 again
  7. In 'Boot' tab: your USB drive should be listed - change the order
  8. Press F10 to save & exit
  9. Your Zenbook should now boot from the USB drive
  10. profit

(*) = and 'Enable CSM' if you want to boot in legacy mode

If that does not help, you might need a more recent firmware version.

Just in case you run into more trouble while trying to install Windows onto your GPT SSD - this post might be very helpful: http://www.hodgin.ca/2012/10/02/creating-a-uefibios-windows-7-usb-and-installing-to-gpt-partitions/

share|improve this answer
    
I had the same problem. I went into BIOS, Boot tab, then enabled Launch CSM...F10 to save and exit, hit Esc on restart and I get that menu where I was able to select USB to boot from. Thanks for the help guys! –  Jim Syyap Mar 22 '13 at 10:40
    
Enabling CSM did the trick for me. Although my situation was slightly different: I wanted to install Win7 on my Zenbook running Win8. Bootable USB drive would only show up in UEFI when CSM was enabled. Thanks! –  simon Apr 21 '13 at 15:30

I hit this same issue. However, if you plug in the USB stick before you boot, the choice will turn up. You can then save and boot away.

IN THEORY.

I tried to boot onto an Ubuntu USB - I see the grub loader but nothing happens after that. But that's a different issue :-)

Last note: Once you remove the USB stick, it will disappear from the options. Next time you want to bot from USB (or a USB DVD, whatever), you'll need to do this again.

EDIT 12-12-12: OK, I managed to get this working with Ubuntu. What I needed to do was turn off the "Secure Boot" option in UEFI/BIOS. Once I did this, it was pretty smooth sailing. Ubuntu installed and all was well with the world once more. This page here: https://help.ubuntu.com/community/UEFI was the best help I found.

Note: Disabling secure boot also meant that I had no issues at all getting both a USB and USB CD-ROM to appear in the boot menu on startup (hitting ESC). You do need to have them plugged in on boot (as it happens so fast), but messing around with the boot order as I mentioned previously became unnecessary.

As always, YMMV - this worked for me, I hope it helps you.

share|improve this answer
    
Mine still does not show up. What BIOS version are you on? Mine is 214. –  Chace Fields Nov 18 '12 at 13:39
    
Sorry, I'm not able to check now (I was doing this on a friend's machine - I'll ask them). It's a brand new machine, so assume the latest bar maybe one or two revisions - max. –  Annoyed Chipper Nov 18 '12 at 13:55
    
Just looked at your screenshot more closely - the one I was using was definitely different with more features. I suggest you perhaps update the BIOS (although it's pretty odd it can't pick up a USB stick. Hello? 2001 called, they want their tech back) –  Annoyed Chipper Nov 18 '12 at 13:58
    
Darn, sorry Chace, I totally forgot to check the BIOS version. –  Annoyed Chipper Dec 12 '12 at 8:56

We just got a few of these in at work and they are a right PITA to wipe and clean-install windows with, especially the usb-3 only ones.

To enable booting to a USB device you need to set secure boot to disabled (in the security tab of the bios) and enable CSM (on the boot tab of the bios)

You can then select a USB boot device.

If you are trying to install windows 7 on a USB3 only zenbook, your next headache will be windows setup failing, from either a bootable USB memory stick or a USB DVD drive. This is because the bios loads the windows boot image, but when the windows setup program starts it doesn't have USB3 drivers and can't read the setup files.

To get around this you need to create a customized windows setup, on either a USB memory stick or a DVD. You need to download the USB3 drivers from asus, extract the driver files (from the folder containing the .sys and .inf files) and use dism.exe to load these into a windows boot image. There are tutorials on how to do this on the net, the one I used was here: http://forums.mydigitallife.info/threads/32302-How-to-install-Windows-7-from-a-USB-3-0-Thumb-Drive-(FAST-installation!)

share|improve this answer
    
I wonder, why you still had 0 upvotes - your solution works (checked on Asus UX21A). Thanks! –  Spook Mar 30 '13 at 21:24
  1. Power on
  2. F2 to enter BIOS
  3. Tab to Boot
  4. "Secure Boot" -Disabled
  5. "CSM + UEFI" selected in OS Mode Selection
  6. F10

  7. Hold F2 to Enter BIOS

  8. Check boot -> Boot Priority to see if connected USB is listed

I use sandisk Cruzer.

share|improve this answer
    
This was the solution... –  Hasan Gürsoy Nov 15 '13 at 18:48

Those are not BIOS setup screens, they are UEFI setup screens (which is the successor of BIOS). Note that UEFI cannot per se boot from media that are made bootable for a BIOS (like install media for most operating systems or rescue systems, which were released at a time where UEFI was not yet available, like last year or so) unless you enable CSM (compatibility support module) support.

So, either you have a boot media that is UEFI bootable (maybe in addition to bootable via BIOS), then you just have to attach it and it should be possible to select it in that menu, or your media is "only" BIOS bootable, then you have to enable CSM support and reboot and go into the BIOS setup of the CSM module to configure booting it from there.

share|improve this answer

I just had this same problem with exactly the same symptoms on an ASUS K56CA that I unboxed yesterday, and boy I am glad I did not come to this thread first. Lots of good advice, but none of it (would have) helped me!

Try a different USB stick. I was using a U3 16GB stick that never had problems booting on any BIOS-based computer, and I could never get it to show up reliably in the boot menu. (Once it appeared in F9 menu, only after I had removed it during boot.)

I switched to a 2GB "24x" PNY Attache I had lying around, with no embedded U3 partition, and it showed up immediately when I had any EFI-supporting image copied to it. Unfortunately I still was not able to boot from the USB. (Grub would load, but no love after selecting any choice from the boot menu.)

Finally I was able to boot Ubuntu using a DVD media with the same image written to it. The helpful folks in the #ubuntu /freenode IRC channel informed me that you do not need a special image secure-linux-12.10-anyfoo.iso as the Ubuntu guide instructs, just use an up-to-date 12.10 amd64 image and it will have included EFI booting support.

For me, after all this, it happily showed up in either F9 or ESC menu for alternate booting.

share|improve this answer

This thread helped me a lot. I'll add my 2 cents:

Asus R509C with Windows 8 pre-installed:

  • USB device is plugged in
  • F2 to BIOS
  • Switch to "Boot" and set “FastBoot” to Disabled
  • Switch to "Security" and set "Secure Boot Control" to Disabled
  • F10 to save and exit and immediately press F2 to BIOS
  • Only then could I switch to "Boot" and set “Launch CSM” to Enabled
  • F10 to save and exit and immediately press F2 to BIOS
  • Now select a boot option. My USB option didn't say USB, it was just [ 8.0.7]
  • F10 to save and exit - booted right to USB
share|improve this answer

I found this: http://www.makeuseof.com/tag/how-to-access-the-bios-on-a-windows-8-computer/ - this might help you out but I am still having issues booting to a device...

share|improve this answer

All recent hardware supports booting from a USB drive. Look for "boot" in the contents index and flip through those pages 8^).

share|improve this answer

I just got 5 of these for my company and am having the same issues. The first thing I want to do is take a full backup using Acronis Snap Deploy and I cannot boot into the software via USB Thumb Drive, it sees the drive but doesn't boot to it.

I also tried hooking up an external Sony DVD drive and it doesn't even see it in the boot options, which is even worse. I called support and they are useless. They guy pulled out a Zenbook and goes "it works for me!" Wonderful.

Next I tried building a Windows 7 Thumb Drive, which the computer notices in the Boot Menu but does not boot to it, goes right into the Asus Windows 8 startup logo. What am I doing wrong? Did you find a resolution to boot to USB? I have BIOS version 214.

BTW, all devices and attempts were tried on a Dell Optiplex 980 and successfully booted to the device...

share|improve this answer
    
I haven't found a solution for the issue. A friend thought he read something about how they were locking out boot options on purpose. How can they do that? I can't believe I can't even do a clean wipe on the machine. Extremely frustrating. Not to mention the backlight bleed all over the bottom of the screen. I've heard their tech support is brutal too. No wonder why Apple wins. –  Chace Fields Nov 20 '12 at 20:30
1  
I had to campaign so hard to get the money to buy these laptops. If that's the case and I have to return them I am going to flip out. Aside from making me look bad, this was an egregious waste of time. I guess my next laptops will be the Samsung Series 9 and if worst comes to worst then the Dell XPS 13. I'm going to call Asus back right now and raise hell... –  chris Nov 20 '12 at 20:33
    
I'm looking at the Series 9 too. If you get them and wouldn't mind letting me know if you can successfully boot, that'd be great. I'd appreciate it. Good luck. Not certain how anybody would want to buy Asus moving forward. –  Chace Fields Nov 20 '12 at 20:35
    
I am on the phone with them now and they are looking into the issue. He says that machines that come with Windows 8 are not recommended to be rolled back. Whatever. I mentioned that people are speculating that Asus is blocking booting to devices and he denies that's the case. If this ends of being the case, I am going to unleash a web forum onslaught everywhere I can about this issue. I am in the NYC area and know a lot of IT people too, if I can prevent even one sale of this hunk of crap, then it'll be worth it. I feel ripped off... –  chris Nov 20 '12 at 21:01
    
I posted a review on Newegg, and an Asus tech wrote and said "Unfortunately with Windows 8 you can not boot from bios." –  Chace Fields Nov 21 '12 at 0:21
  1. Enter the BIOS setup menu by pressing and holding F2 key when powering on.
  2. Switch to "Boot" and set “Launch CSM” to Enabled.
  3. Switch to "Security" and set "Secure Boot Control" to Disabled.
  4. Press F10 to save and exit.
  5. Press and hold ESC key to lunch boot menu when the notebook restarts.
share|improve this answer

If your USB drive does not show up, try a different drive.

I couldn't get it to boot from USB DVD on two different model Zenbooks. It wound up being a compatibility issue with the DVD drive. A new DVD drive booted just fine.

share|improve this answer

protected by Community Nov 18 '13 at 20:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.