Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I haven't been able to figure out what is slow and why Windows seems to be immune.

When navigating to a page it can take 15 seconds or more to begin or fail with a time out. Once the page starts loading it isn't slow and generally I can navigate within the domain with no issues. But ultimately it isn't consistent.

I run Debian Testing with Firefox. I also use Dolphin on Android, but usually I see this issue with pushing tracks to openstreetmaps. I also attribute such to the inability to remote desktop from the Windows XP virtual machine.

When looking at similar issues people would find issue with the DNS or ipv6 resolution. When I run ping or host against the problem domain I get standard response times. (Well kickstarter.com doesn't appear to respond to ping at all).

I haven't reached out to my ISP since I've had no luck reproducing this in Windows (same machine same connection). And also since I haven't been able to consistently reproduce it, but it is very common.

And I have removed my personal router from the equation. And reset the Westel modem so I didn't have strange configurations.

The problem started at some time when my personal router reset several of it settings or something. At least I can't think of any other changes I'd made between network working fine and suddenly being slow.

Any tips on things I can try or what I should be asking my ISP to look into would be nice. I'll be working in chromium for a bit, but that wouldn't help with other symptoms anyway.

share|improve this question
    
what does FF say in the bottom left corner while the lag is occuring? –  Frank Thomas Nov 18 '12 at 0:14
    
@FrankThomas Pretty sure it is the "waiting for" I'll have to double check when it comes up. Confirmed. –  he_the_great Nov 18 '12 at 0:15
    
do you get the same result when you run FF with addons disabled? kb.mozillazine.org/Safe_Mode –  Frank Thomas Nov 18 '12 at 0:22
    
see here for some advice on troubleshooting these types of problems: forums.mozillazine.org/viewtopic.php?f=38&t=1959113 –  Frank Thomas Nov 18 '12 at 0:22
    
Just to rule it out completely, have you tried changing the DNS servers you're getting from your ISP? I had similar problems, strange ones, a while back until I manually changed from the ISP's DNS servers to other public servers. And since Windows caches DNS entries, it might explain why Windows is working better. –  trpt4him Nov 18 '12 at 1:35
show 4 more comments

1 Answer

up vote 0 down vote accepted

After having received a new modem from my ISP the internet has not demonstrated the issue I've described in the question.

I'm not sure if there are any other approaches to test the modem for this specific problem, or if there was a configuration I could have changed to correct the problem.

(I shouldn't be hypothesizing here) Considering I'd reset the Modem multiple times I expect they made configuration changes on their end which were not compatible with my older modem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.