Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem where dwm.exe keeps suggesting I disable Aero to improve my performance whenever I play either Battlefield 3 or Anno 2070.

I get three choices:

  • Disable Aero
  • Don't disable but ask again.
  • Don't disable and never ask again.

The last one is the only acceptable choice. But still it doesn't keep the pop up from appearing every time I run a full-screen application.

I've tried:

  1. Changing Action Center settings to not show Windows Troubleshooting messages.
  2. Disabling Windows Performance Logging and Alerts in the service manager.
  3. Making changes to perfmon.

Disabling Desktop Composition, either on a by-program basis or completely, is NOT a valid solution to this problem.

There is no problem with my resources or performance, I just want to get rid of this Windows bug.

Again, to clarify: my rig can handle running Aero, VLC with a 1080p movie in one screen and Battlefield3 at 120fps in the other without as much as a hickup, I just want the pop-up gone for ever without having to sacrifice Aero.

I've had Windows 7 x64 on three machines by now, some much lower-performing than my current, and it is the first time I'm having this problem.

Please help!

share|improve this question

marked as duplicate by Tog, Scott, Brad Patton, Ƭᴇcʜιᴇ007, Renan May 4 '13 at 19:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Sounds like you should contact the game developers and request an enhancement. –  martineau Nov 18 '12 at 14:24
1  
@martineau, and what about the dozens of other programs that trigger it? It’s not a problem with the game, it’s Windows that needs to be more user-friendly. –  Synetech Nov 18 '12 at 14:41
1  
Have you tried clicking Don't disable and never ask again? As it suggests the Aero will be left enabled, and this question will never be asked again. –  Alexey Ivanov Nov 18 '12 at 18:56
1  
@AlexeyIvanov Based on "that doesn't keep the pop up from appearing every time I run a full-screen application" it would seem that option doesn't work as intended. Anyway, as far as I know, the message itself is triggered when Windows detects that the system is running low on video memory. So one workaround might be to lower VRAM usage in the games - reduce texture sizes and lighting quality, disable anti-aliasing and triple-buffering, etc. –  Indrek Nov 18 '12 at 19:08
1  
After some more testing, this appears to be a Glitch or Bug within Windows. I've now tried many more fullscreen-applications, and regardless of whether I use DX11 or DX9, this message pops up for no reason. Whenever I run the same applications in windowed mode, this does not occur, the performance of the system however, heavily decreases. To sum it up: - Pop-up appears when performance of the system is good. - Pop-up does not appear when performance is low. - Cannot be disabled. - Bug that only Microsoft can fix. Now, how do I contact Microsoft support...? –  Havoc Dec 5 '12 at 1:24

3 Answers 3

up vote 7 down vote accepted

I've finally found a solution!

Since Windows doesn't understand how resources work, you need to keep it from checking them:

In regedit go to:

HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM (create if not already existent)

Set a new DWORD UseMachineCheck with a value of 0.

This will keep Windows from checking if your computer "performs slowly" and thus attempting to disable Aero.

Solved all my problems!

share|improve this answer
2  
nope , didn't work for me. the message still appears. –  Rodniko Nov 8 '13 at 16:47
    
Didn't work for me either. Maybe its for vista but not win7 –  Geo Papas Mar 1 '14 at 23:33

You need to disable the message itself, although this will most likely disable other messages relating to performance.

- Go to your Action Centre, type that into your Start Menu and open it.
- Choose "Change Action Centre Settings" from the sidebar on the left.
- Untick the "Windows Troubleshooting" checkbox near the bottom of the window.
- Click "OK".

That should subdue the message for you.

share|improve this answer
3  
Unfortunately, as I've already stated in the original post, the checkbox "Windows Troubleshooting" has no apparent function, it has not disabled the pop-up or any other system related baloon or pop-up. –  Havoc Dec 5 '12 at 1:28

The solution comes in two steps:

step 1:

  1. Open up Quicktime
  2. Edit > Prefrences > QuickTime Preferences
  3. Advanced Tab
  4. Under Video in Advanced click Safe Mode

step 2:

Run menu > sysdm.cpl > Advanced Tab > performance > select adjust for best performance > make sure you do not allow Windows to choose for you because your computer does not know whats best --- Make sure Enable Aero Peek is checked

---- OR ---

Right click my computer > properties > Advanced System settings > performance > select adjust for best performance > make sure you do not allow Windows to choose for you because your computer does not know whats best --- Make sure Enable Aero Peek is checked

note: if you are using "Doublesight DS-70U" , a bad "smart USB monitor" driver might be the cause.

note2: this link might also be of help.

credits: forum link

share|improve this answer
    
I don't see how this could be a solution. I have this exact problem and I don't even have Quicktime installed, not to mention setting performance settings like that will degrade the appearance of everything, which is exactly what the OP wanted to avoid. Frankly, I think you've pasted the answer to an entirely different problem into this question. –  Alain May 1 '13 at 16:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.