Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hardware:

  • Intel i7 2600K (not overclocked, SLAT compatible, virt. features enabled in bios)
  • Asus Maximus IV Extreme-Z (Z68)
  • 16Gb RAM
  • 256Gb SSD
  • Other non-trivial working parts

Adding Hyper-V is causing a boot loop resulting in an attempt at automatic repair by Windows 8 after the second or third loop:

I'm trying to get the Windows Phone 8 SDK installed and I've narrowed down my troubles to the Hyper-V feature in Win8. This is required to run the WP8 emulator and there are no install options to omit this feature.

My first attempt completely borked the OS as I did not have a recent restore point or system image, so I did a completely clean install and made plenty of backups/restore points. I skipped the SDK install and went straight for the windows feature add-on for Hyper-V. This confirmed that Hyper-V is the issue as the same behavior resulted.

I cannot find any hint in the Event Logs. Cancelling automatic recovery causes the same behavior to repeat. I don't have any other VM products installed. My only recourse is to use a restore point, try something else, install it again, and see what happens. No luck so far.

I'm on my 10th attempt here. Any help would be much appreciated.

EDIT:

I found a collection of tips here.. http://social.msdn.microsoft.com/Forums/en-US/wptools/thread/b06cc9f2-aa5e-4cb3-9df1-0c273e1dfd68 So i've been attempting various bios settings to resolve this issue with no luck. I've tried setting 'CPUID Limit' to disabled. This seems to work partly as Win8 boots but no USB devices work at all. I also attempted disabling the usb 3.0 controller as the msdn topic lists an issue with USB controllers on Gigabyte boards. This also doesn't work. The USB devices light up but no input is received by the OS. All of my other bios CPU settings are in line with the info in the post. I'm totally stumped.

Bios screenshots:

http://i.imgur.com/JEWeS.png

http://i.imgur.com/mO02y.png

http://i.imgur.com/yKN5u.png

http://i.imgur.com/Y9wI4.png

http://i.imgur.com/F6EuO.png

share|improve this question
    
Have you seen/tried this: superuser.com/a/379300/23133 ? –  Ƭᴇcʜιᴇ007 Nov 18 '12 at 21:30
    
Can you find any Hyper-v installation logs? It's a reach, but look in %temp% for some. There's got to be something erroring out somewhere and maybe leaving a log when it does so. –  Mark Allen Nov 18 '12 at 22:19
    
Nope, can't find any logs.. :( –  NickSuperb Nov 18 '12 at 23:32
    
@techie007 thanks but the issue isn't installing it, its after its installed. –  NickSuperb Nov 19 '12 at 3:24
    
@Nick maybe change your question title then, which says that you can't install it. –  Mark Allen Nov 19 '12 at 6:03

2 Answers 2

up vote 0 down vote accepted

I was able to come up with a temporary solution to get the installer to complete and system rebooted:

When you reach the very last screen in the SDK installer where a request to reboot is made, hold off on that and without closing the installer, launch control panel. (Ctrl-x > Control Panel)

Go to Programs and Features and modify your Windows features. Hyper-V should be checked as was implemented by the SDK installer. Simply uncheck it click OK and wait for the process to complete. Once done you can now click to reboot in the SDK installer. It should reboot and complete successfully but without implementing the Hyper-V features.

As of yet there is no permanent solution that I can find. However, you should be able to perform testing and debugging on an actual WP8 handset in place of the Hyper-V virtual machine.

share|improve this answer

This is an old question and I don't know if you ever got resolution, but for me it was using an MBR disk on an EFI machine. If I reformatted my system drive as GPT, Hyper-V would work properly.

You can also turn off the hypervisor from the auto repair command prompt with bcdedit /set hypervisorlaunchtype Off - this will 'install' hyper-v, which allows the install to finish, but Hyper-V won't work. It'll show up as an installed feature, allow you to add a machine, but once you try to start the machine it will fail.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.