Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 8's desktop search seems not to index PDFs. Is this by design or have I misconfigured something?

share|improve this question
    
This issue also can happen on W7 - the answer my also help you answers.microsoft.com/en-us/windows/forum/windows_7-files/… –  Dave Rook Nov 19 '12 at 8:51

3 Answers 3

up vote 8 down vote accepted

Windows 8 should be able to index PDFs out of the box. Just press Win+W / type "index" / Indexing Options / Advanced / File Types tab, select PDF and ensure that Index Properties and File Contents is selected:

1

Also, as per this Adobe forum thread, seems like installing Acrobat XI can actually break Win8's PDF indexing ability. Considering the fact that Adobe's iFilter/preview handler+thumbnailing feature has been broken for more than 3 years now, this comes as no great surprise to me. Adobe has responded with an official workaround to restore the native Windows 8 PDF iFilter functionality.

share|improve this answer
1  
It is selected in mine, but it says "Registered IFilter is not found". Can you verify that it works for you? If Acrobat is to blame, I need to find a way to disable its iFilter without uninstalling it altogether. –  Emre Nov 20 '12 at 19:24
    
I don't have any crap from Adobe installed for handling PDFs, and no PDF iFilter installed either. I just tried changing the Indexing Options and when the Plain Text Filter was activated for PDFs instead of the File Properties Filter, search correctly found PDFs with the text I specified. The only other PDF iFilter I know of is Foxit's, but no idea if it works in Windows 8, plus it is not free. –  Karan Nov 20 '12 at 20:15
    
To be clear, the text it found was inside the PDF, not the title or metadata, correct? –  Emre Nov 21 '12 at 22:36
    
Yes, it was inside the PDF. –  Karan Nov 21 '12 at 22:40

This issue also can happen on W7 - the answer my also help you http://answers.microsoft.com/en-us/windows/forum/windows_7-files/i-need-to-index-pdf-files-in-my-laptop-running/ef5fa7c3-bb64-4f3e-9607-3e01349dccca

So, for Windows 7:

Go to Indexing > Advanced > File Types, and remove the check for PDF. Press OK > Press Close.

Then uninstall any Ifilters that you have relating to searching PDF Files.

Re-install Acrobat if lower than version 9.3

share|improve this answer
    
It says "Registered IFilter is not found". Do Windows 8 or Acrobat XI not come with one? –  Emre Nov 19 '12 at 17:28
    
I think it is not supported. adobe.com/support/downloads/… Here you can see what iFilters you can download and it only mentions Windows 7 (despite saying 64bit) –  Dave Rook Nov 20 '12 at 8:57

This worked for me in Windows 8.1 with MS Reader, Adobe Reader and Foxit Reader installed:

Change registry key per Adobe's instructions.

Restart (may not be needed).

Win+W, select Index > Advanced and click "Rebuild" under Troubleshooting.

Now Windows Explorer shows PDF content in the search results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.