Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just upgraded my laptop from Windows 7 Ultimate with IE9 to Windows 8 with IE 10. When ever I try to open a web link in an application nothing happens.

For example in the Windows 8 mail application it makes the email address in an email look like a link. When I click on these with the mouse the link changes to look like I have clicked on it, but aside from that nothing happens.

I have tried making sure that IE 10 is my default web browser and been into IE10's settings and associated it with all the usual file types, but still no success. Has anyone got any ideas what might be causing this?

I have a feeling this started when the Browser Choice update ran. I couldn't select which browser to install in that either. The install buttons just flashed when I clicked them and then nothing.

Something else I tried was going into the Programs and Features control panel and removing IE10 rebooting and then going in and adding it back. This does not seem to have fixed the issue either.

UPDATE: This is now sorted. A very helpful chap from Microsoft Support deleted a registry key that was causing the issue, though I didn't quite catch which one.

share|improve this question
I would run the browser choice application again to reset your choice. – Ramhound Nov 19 '12 at 11:32
@Ramhound I tried this several times. It appears that browser choice requires the facility that is not working. – Martin Brown Nov 19 '12 at 12:29
So I decided to install chrome. Opened up market place and found Chrome's page. Chrome can only be installed from a link which isn't working. – Martin Brown Nov 19 '12 at 12:32
Copy and paste the link into the address bar. – Ramhound Nov 19 '12 at 12:42
There is no way to copy it. – Martin Brown Nov 19 '12 at 12:45

In many applications, hyperlinks do not open Internet Explorer 10. It can be very frustrating to have an application like mail, Skype, Teamspeak, or a custom application that sends an HTTP request through Internet Explorer, only to have nothing happen after clicking on the link. The problem with Windows 8 is that now the shell command that would open IE10 has a “Delegate Execute” command in the registry that points the HTTP hook elsewhere. The problem may also happen with other browsers, such as Google Chrome. Fortunately, the problem does not occur with applications opening links with Mozilla Firefox enabled as the default Internet Browser. A good test to see if you’re having this obscure problem is to set FF as the default browser and test if links do open. If the link does not open in IE but opens in FF, then the following is the solution to make IE open when links are clicked.

Open a text editor in Windows 8

Copy and Paste the following:

Windows Registry Editor Version 5.00



Save as IEFix.reg (Make sure it is .reg, not a .txt)

As an Administrator, merge this registry change. Either Double-Click in an Administrator account or run CMD as an Administrator and open the .reg

Make sure IE is set as the default browser.

Links will now work in programs and open in IE.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .