Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Win 8 Pro, over the top of Win 7 (64-bit both of them) with keep nothing option. After the first (only?) restart I see the Win 8 logo and after about 30 seconds I get the new BSOD screen (sad face screen), which disappears too quickly to read the error message detail. The computer then reboots and goes to an OS selection screen with choices for Win 8, Win Setup, and Win 7. Trying to boot anything other than Win 7 fails with the same error. Booting into Win 7 gives me a message from the Win 8 setup that everything was restored, but there is no option to see logs or troubleshoot.

The computer is a Sony Vaio T series laptop - purchased in August, so its relatively new hardware (model SVT13115FG for those interested). I have updated all drivers (including the BIOS) using Sony's Win 8 readiness tool. The same error happens whether I try going through the install or upgrade path (have licence keys for both). The below is a the only log files I've been able to find that look relevant.

setupact.log from C:\$WINDOWS.~BT\Sources\Rollback

setupact.log (~5Mb download) from C:\$WINDOWS.~BT\Sources\Panther

I don't have a clue where to start troubleshooting this so any pointers would really help.

Cheers guys!

share|improve this question
2  
If you selected keep nothing option then you should be able to boot into Windows 7. This means the installation failed and what you are booting into is a half-installed Windows 8. Have you tried just running the installation again? If you don't want to keep anything just boot to the Windows 8 Media Disk –  Ramhound Nov 19 '12 at 12:13
    
i was selecting keep nothing but I started running the setup not from boot but from windows... I'll try booting directly into the win 8 setup –  Darko Z Nov 19 '12 at 20:42

1 Answer 1

up vote 3 down vote accepted

This phenomenon sounds exactly like booting into the OS when it is missing your RAID/AHCI driver, OR booting into the OS with RAID/AHCI enabled in BIOS when it should be set to IDE.

I would recommend that you look for a preinstall driver for Windows 8 from Sony.

Something like this usually happens when it is loading drivers from disk and initializing them, it is either loading a default IDE driver and realizing your disk is booting in RAID/AHCI, OR loading the RAID/AHCI driver and realizing your disk is booting in IDE. This will cause Windows to not be able to boot.

Hope that helps!

share|improve this answer
    
I have tried to run an automated Win 8 readiness tool from Sony, which claims to have updated those drivers, but I'll try manually update them and report back –  Darko Z Nov 19 '12 at 20:37
    
Allright, getting somewhere now! I've booted from USB to start the install, and when choosing the disk to install to there was nothing there! So, it's missing the HDD driver. Now I have to figure out how to get it - seeing as I'm not sure what the exact model of the HDD is and the Sony download drivers are just exe's –  Darko Z Nov 19 '12 at 22:21
    
Your hunch was exactly correct, I found the driver for the HDD on the Intel site, copied it across to the boot USB, booted from USB, on drive select loaded the driver from the USB and no hitches from then on. Cheers! –  Darko Z Nov 20 '12 at 3:53
    
I'm glad I could be of assistance :) –  Brutick Nov 20 '12 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.