Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use Komodo IDE 7 (7.1.3) to debug a Zend Framework (PHP) project. The project is being served by Apache on a Ubuntu Server and I am using Komodo on Windows 7 on the same LAN. The files are on a mapped drive corresponding to the root folder of the web project.

When I start the Zend Framework debugging, by loading a page with Chrome's Xdebug Helper activated, Komodo will warn me about a debugging session being started and correctly load the index.php file that starts the Zend Framework (and loads the bootstrap). However it does not stop on breakpoints, in any file. If I step into/over function calls it can go into files (although it complains about URI mapping and opens files in read-only) but it doesn't stop on breakpoints.

What am I missing in the configuration for it to stop on breakpoints? Is this possible at all?

share|improve this question

Use the debugger connection preferences to change the port that Komodo listens to from the default value of 9000 to one of the following:

share|improve this answer
    
I have posted an answer - the problem was the lack of URI mapping. – Technoh Aug 6 '13 at 20:08
up vote 0 down vote accepted

After posting in the ActiveState Komodo Support forums I followed instructions to add proper URI mappings to Komodo IDE's configuration. After reading the documentation I thought Komodo would pick it up automatically but once I set up a URI mapping for each main directory (e.g. controllers, views, models ans so forth) it was working flawlessly.

For more information, see the thread at http://support.activestate.com/node/9261.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .