Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 8 Pro on an Apple MacBook Pro 9,1 Mid 2012 15 inch non retina. It has a Core i7-3720 QM CPU @ 2.6 GHz. For the past few days, I have noticed that it is constantly running at max speed which is 2.59 GHz. Before, it used to run at 1.5 - 1.8 GHz on normal usage. And, the weirder thing is that CPU usage is minimal.

Screenshot:

Processor at max speed

So, what is the reason for this? And is it harmful?

share|improve this question
    
Are you using Bootcamp? Why wouldn't you want your processor running at full speed? –  Ramhound Nov 19 '12 at 15:31
    
I would say that you're worrying for nothing really. According to Intel's ARK tool (ark.intel.com/products/64891) your processor is rated for 2.6GHz base clock. Therefore, there should be no real issue with it running at that speed. Also, if you noticed the core clocks were lower, check your power settings in BootCamp(?). Chances are it downclocks the processor to lengthen battery life. –  Brutick Nov 19 '12 at 15:35
    
Yes I'm in bootcamp. But it never ran at 2.6 consistently. Always lesser. That's why I was worried. Why isn't it downclocking to lengthen battery life then? –  pratnala Nov 19 '12 at 15:41
    
Which power plan do you use? switch to "Balanced". The issue can also occur if you've enabled Hyper-V. –  magicandre1981 Nov 19 '12 at 21:37
1  
Worth noting that if it is down to Hyper-V, the processor does still drop speed but Task Manager can't see it any more due to the hypervisor layer. –  Graham Wager Nov 19 '12 at 21:56

3 Answers 3

up vote 5 down vote accepted

I noticed the same issue when Hyper-V was enabled.

Hyper-V works by running a hypervisor layer between the bare metal machine and all operating systems running on it - including the host. It is this hypervisor layer that interacts directly with the system including the CPU, and so the host OS can only see the hardware that the hypervisor reports to it:

enter image description here

In this situation, the hypervisor reports to the OS the full speed of the processor and so it appears that dynamic multipliers (which is how the system reduces the CPU speed under low load) are not working however they are actually still active and being controlled by the hypervisor itself.

As such, there is nothing you need to do as the system is actually behaving as you want at the hardware level.

share|improve this answer

Task Manager will show the maximum capable speed, not necessarily the current one.

Try seeing what CPU-Z reports.

Core Speed: Task Manager vs CPU-Z

share|improve this answer

Try Creating a "no hypervisor" boot entry if you dont really care about hyper v running all the time http://blogs.msdn.com/b/virtual_pc_guy/archive/2008/04/14/creating-a-no-hypervisor-boot-entry.aspx

share|improve this answer
    
Yeah I did this only. Thanks for the tip though. –  pratnala Oct 19 '13 at 7:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.