Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to add a button to run a macro in Access 2007 to my Quick Access Toolbar (QAT).

In Excel 2007, I have never had an issue. In the Customize Quick Access Toolbar window I can select Macros from Choose Commands From and then all my non-private macros are listed. I can add them to my ribbon.

However, in Access 2007 nothing shows up in this list of Macros. I feel like there is something in the fundamentals of Access and Macros I am missing but not sure what ...

Thanks for your help.

Adding module example saved as TestModule (see screenshots as well). I still feel I am missing something very simple here ... sigh

Option Compare Database
Option Explicit
Public Sub HelloWorld()
    MsgBox "Hello world!"
End Sub

1st Screenshot

enter image description here

share|improve this question
add comment

1 Answer 1

In Access the macro's are per-database (and per-user), and what that list is showing you is the all the macro's in the currently opened DB.

So if you setup a Macro for a database, and then close it, the macro is not available in the list anymore.

share|improve this answer
    
In the database I have open I have Module1 and Module2 (under the Module group) which are saved with the database and contain my Macros ... but they don't show up in the list ... is that what you meant? –  thornomad Nov 19 '12 at 19:24
1  
If the Sub's in the module are marked as Private, then they probably won't be available in the list; try marking them as Public. Additionally, if the Module itself is marked with Option Private Module, this may make them unavailable (as well). Perhaps edit your question with information about where the macro's reside, and if possible, post an example macro you're trying to use. –  Ƭᴇcʜιᴇ007 Nov 19 '12 at 19:37
1  
Per your suggestion I added more details as well as a couple screenshots; I feel like I somehow have my hat on backwards with this one. Thanks. –  thornomad Nov 19 '12 at 19:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.