Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the problem on one of my machines that it is not possible to select WPA2-PSK [AES] network. It is missing in the network encryption dropdown (please see a picture below from my computer where it shows (and works), on the other computer the currently selected alternative AES does not show)

Any pointers on how to get it added are much appreciated.

alt text

share|improve this question
please give me some points and I can add a picture :-) – HKK Oct 4 '09 at 18:11
Your NIC (hardware, possibly driver) may not support WPA2. What brand and model? – hyperslug Oct 4 '09 at 18:20
IBM T41, more than a couple of years old by now – HKK Oct 4 '09 at 19:08
up vote 0 down vote accepted

Simply put, you need either a newer network card, or a newer driver.

Forget the brand of device you bought and just take a look in device manager for the actual chipset maker - Atheros, Realtek, Intel etc.

Go to the site and see if there is an updated driver you can use.

If an update does not work, it means that WPA2-PSK is simply not compatible with your current card and you will have to buy another.

share|improve this answer
I think WPA2 support comes from the OS, not the network card driver. – pipTheGeek Oct 4 '09 at 19:23
Maybe, not 100% sure if there is a minimum OS requirement, but what I said certainly does count. I get jobs like this all the time where a new laptop does not support WPA2-PSK and all it takes is a driver update and suddenly the option appears. – William Hilsum Oct 4 '09 at 19:29
Thanks for help. Have updated the drivers and unfortunately no WPA2-psk option appeared. I am not really comfortable with a lower encryption level like WEP so I will keep that machine on the LAN. – HKK Oct 4 '09 at 19:49

Update for Windows XP (KB893357) This update to Windows XP provides support for Wi-Fi Protected Access 2 (WPA2), which is the latest standards-based wireless security solution derived from the IEEE 802.11i standard.

share|improve this answer

Make sure you have (at least) Service Pack 2 installed. If you can't install it for some reason, there's a hotfix.

share|improve this answer
Shouldn't it be Service Pack 3? (IIRC, you need either SP2+hotfix or SP3) – CesarB Oct 13 '09 at 15:03
I have SP3 loaded and the option is not available. – Chad Jun 4 '10 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .