Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When in the office, I'm connected to a 192.168.1.0/24 network. When Internet Sharing is off, when I run

netstat -nr 

the first entry shows

default            192.168.1.254      UGSc           10       62     en0

If I turn Internet sharing on, it shows

default            link#5             UCS             2        0     en1

This is obviously incorrect and breaks all connectivity of my machine.

en1 is my wireless, whereas en0 is my Ethernet. If I then disable Internet Sharing, it even deletes that incorrect route, so I'm left with no default route at all.

Currently I have one script that I run when I share, or after, when I disable that does

route delete default
route add default 192.168.1.254

That fixes everything, but I'd love to know what's actually making this happen and how to properly fix it.

And just to say that at some point a few months ago, this was working absolutely perfectly, with no hitches, then one day when I brought the laptop home, I couldn't disable the internet sharing, so I couldn't connect to my home WIFI. I eventually had to restart the machine and since then this problem has been happening.

share|improve this question
1  
+1 just for a good description if the problem. –  Hennes Sep 17 '13 at 16:30
    
In the Network settings, check the ordering of the different interfaces. It may be that the interface you are sharing with has a higher priority than the interface the indented default gateway is on. –  yorn May 15 at 20:47

1 Answer 1

I don't know if it's directly related, but your setup is wrong. That could be why the config is resetting.

On your 'internal' interface you're manually setting the IP address to 192.168.1.254/255.255.255.0, and that's fine, but this interface should have NO router address specified. In your case you've set the router address to the server itself, which is never going to be accurate.

Secondly, the DHCP settings don't have a router address set. This means that your DHCP server will hand out addresses to clients, but won't tell them how to get to the outside world. Hardly seems appropriate to me.

In your DHCP settings you should set the router address to the address of your NAT server (in this case 192.168.1.254).

Try those fixes and see if it makes any difference.

share|improve this answer
    
Nope, none of this is true. Everything was fully DHCP only, and the only time anything was ever set manually was when something wasn't working and just an effort was made to get it back working. As for now, this is an old question, and I no longer use the same OS, laptop, network or Internet Sharing any more, so this ain't an issue! –  seaders Aug 30 at 22:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.