Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one of the new Lenovo Yoga laptoblets, and I can't seem to get it connected to the wireless network at the office (for which I have permission, the SSID, and the PSK). It connects without issue to my wireless network at home (also WPA-2/AES).

I've tried several of the techniques posted around online over the past few months (manual add; connecting to the "hidden network" item in the charms menu; netsh command line scripts), but nothing seems to get me connected. As this machine's sole mode of connection is Wi-Fi, it's obviously an issue I want to resolve.

Are there any other tricks for getting connected to a WPA-2 Personal 802.11g wireless network with this device?

share|improve this question

migrated from serverfault.com Nov 20 '12 at 15:25

This question came from our site for professional system and network administrators.

2  
The best way would be to tell your network administrator to turn on SSID broadcasting (undo the hidden SSID). This will improve security of the network and solve your problem in the same step. –  Hennes Nov 20 '12 at 15:34
1  
Have you checked to make sure the network is not doing MAC filtering or some other lock out technique to prevent the Yoga from connecting? –  BBlake Nov 20 '12 at 15:35
1  
@Hennes - If you could provide more detail on why this improves security, I'm sure that would be useful to him (I know, LMGTFY; it might help to have it here though, too). –  Tonweight Nov 20 '12 at 19:48
    
@BBlake - Yes, I'm reasonably sure it's not MAC filtering (and, if it was, Admin would've probably added already the Yoga's MAC based on my request). –  Tonweight Nov 20 '12 at 19:49
1  
Part 2). It gets worse. SID no longer shouts. Instead I sneak into the room and start shouting "Hi, I am SID, you can talk to me". This is not true, but heck, I can shout (broadcast) what I want. People start talking to me instead. I asked them for their passphases. People think they are authenticating to the real SID and give them to me. Security is compromised. –  Hennes Nov 20 '12 at 20:02
show 3 more comments

1 Answer

up vote 2 down vote accepted

The best way would be to tell your network administrator to turn on SSID broadcasting (undo the hidden SSID). This will improve security of the network and solve your problem in the same step.

Let me use an easy to image scenario:

With SSD broadcasting enabled there is someone a room. Every minute he calls out "Hi, I am SID, you can talk to me". With SSID broadcasting disabled he does not do this. Now I am going to talk to SID. Publicly I yell "Hi SID, this is Paul. Can you put this on the shell for me". Everybody still hears SIDs name and knows it is there. Telling SID not to shout his name every minute does not help to keep things hidden. As long as there is traffic the SSID of the network will be visible to everyone.

It gets worse. SID no longer shouts. Instead I sneak into the room and start shouting "Hi, I am SID, you can talk to me". This is not true, but heck, I can shout (broadcast) what I want. People start talking to me instead. I asked them for their passphases. People think they are authenticating to the real SID and give them to me. Security is compromised.

Imposing as SID should not work if I need to identify myself (read: use a certificate). However that is only the case if WPA2/Radius is used. (Your post mentions WPA-2 Personal, which not WPA 2 Radius).

Hiding the SSID was a sane advice when wireless was new and nobody had written a program yet to sniff the airwaves. These days you download such programs for free. (Heck, people sell kits which can do that for actually helping you to lay out your wireless networks transmitters in optimal places).

@Hennes - Can I ask you to add this information as the answer so I can upvote you/mark this as "the answer?" – Tonweight

Done, though I do not consider it a proper answer to the question. It is a solution. I think it is a good solution. But it does not answer the 'How do I connect to a a hidden SSID network in win-8' part.

share|improve this answer
    
Thanks, @Hennes! Hopefully this will help other folk get connected until a proper solution for Windows 8 appears. –  Tonweight Nov 21 '12 at 15:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.