Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu Linux VM in my Windows XP box.

I am able to open http://google.com on Windows XP but when I login to, Ubuntu linux.. and launch this site: I am getting an error: Server not found.

The network settings I have on LinuxUbuntu VM is :

  • Adapter1 : attached to Bridge adapter.

I tried NAT as well. But nothing seems to work.

I am not in China. I provide google.com as mere example. We have a test website which cannot be launched inside Linux Ubuntu.


I deleted etc/udev/rules.d/70-persistent-net.rules. But this does not help.

The output of ifconfig -a and lspci within Ubuntu is below

ubuntu@ubuntu-VirtualBox:~$ lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:05.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
00:06.0 USB controller: Apple Inc. KeyLargo/Intrepid USB
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)
ubuntu@ubuntu-VirtualBox:~$
ubuntu@ubuntu-VirtualBox:~$

ubuntu@ubuntu-VirtualBox:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 08:00:27:80:0a:92 
          inet addr:10.0.2.15  Bcast:10.0.2.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fe80:a92/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1849 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1372 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1697396 (1.6 MB)  TX bytes:132043 (132.0 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:150 errors:0 dropped:0 overruns:0 frame:0
          TX packets:150 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:20424 (20.4 KB)  TX bytes:20424 (20.4 KB)

The output of ipconfig from the host (win XP) box is
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrator>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 10.43.68.141
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.43.68.5

Ethernet adapter VirtualBox Host-Only Network:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.56.1
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . :

C:\Documents and Settings\Administrator>
share|improve this question

migrated from stackoverflow.com Nov 21 '12 at 7:58

This question came from our site for professional and enthusiast programmers.

    
Anuradha, please go back to Stack Overflow and register your account there. Then, log in with the same account here, and you can edit your question again. Please don't post answers below to reply to others — you first need your account fixed. –  slhck Dec 3 '12 at 12:03
add comment

2 Answers

I suppose, you are in China. So, google sites, due to the GFW, you know. Finally, what I want to tell you is, the network settings should not have any problem and why don't you try any other web sites just like bing.com ? In addition, have you ever set the network of your ubuntu system itself correctly? It's also very important.

share|improve this answer
add comment

I experienced the same problem in the same configuration. The solution was deleting /etc/udev/rules.d/70-persistent-net.rules, Linux configures it on the next boot.

For further investigation, please supply ifconfig -a and lspci from Ubuntu and ipconfig from the host.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.