Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a vps that comes with 16 ipv6. I used one of the addresses and I tried testing the proxy at http://ipv6-test.com/ but it detected that is using the first ipv6 adddress instead of the certain ipv6 address that I provided.

Example I used 2607:f358:0001:fed5:0022:772f:6ed3:7f3c as my proxy but it detected as 2607:f358:0001:fed5:0022:0000:db61:85e1 . Why is it doing that?

The proxy server I am using is polipo

share|improve this question
    
What program are you using to do the proxy? – qqx Nov 21 '12 at 15:24
    
I am using polipo – Ruriko Nov 21 '12 at 22:17

It does that because your proxy is not explicitly binding to a specific address when initiating a new outbound connection. The kernel must choose one. Operating systems may vary on how it chooses the preferred/default address.

share|improve this answer
    
I am using Ubuntu 12.04 LTS. How do you bind all my 16 ipv6 addresses? so I can use them as proxies – Ruriko Nov 21 '12 at 12:10

You have to edit the config assuming you are using polipo as I gleamed from above.

proxyAddress = "IP address you want it to listen on."

http://www.pps.univ-paris-diderot.fr/~jch/software/polipo/polipo.html#Client-connections

share|improve this answer
    
I added my ipv6 address but I get a connection reset but if I use :: as the unspecific address it'll work. It doesn't seem to work when I put one of the 16 addresses – Ruriko Nov 22 '12 at 4:13
    
What are you using to configure your proxy? What settings are you using? – Zero Nov 27 '12 at 17:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .