Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

SOLVED: I reinstalled JDK and it works fine.

When I run Eclipse, it will show the splash screen for a split second and then close.

I tried removing everything like the eclipse and all my workspace folders. Re-downloaded eclipse, un-zipped the file, and it did the same thing when I tried to run it.

I went to the command line and typed this command eclipsec -consoleLog -debug to get some debug results when eclipse starts up. Here is what was outputed:

Start VM: -Dosgi.requiredJavaVersion=1.5
-Djava.class.path=C:\Program Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
-os win32
-ws win32
-arch x86
-showsplash C:\Program Files\eclipse\\plugins\org.eclipse.platform_4.2.1.v201209141800\splash.bmp
-launcher C:\Program Files\eclipse\eclipsec.exe
-name Eclipsec
--launcher.library C:\Program Files\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20120522-1813\eclipse_1503.dll
-startup C:\Program Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
-product org.eclipse.epp.package.jee.product
-vm C:\Program Files\Java\jre6\bin\client\jvm.dll
-Djava.class.path=C:\Program Files\eclipse\\plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
Error occurred during initialization of VM java/lang/NoClassDefFoundError: java/lang/Object

I'm running this on a 32-bit Windows XP machine. I have no idea what this means. Thanks!

share|improve this question
I reinstalled JDK and it works fine. – Rob Avery IV Nov 21 '12 at 14:14
Please post that as an answer, and self select when you can – Journeyman Geek Nov 21 '12 at 14:16
@JourneymanGeek I can't, lol. I have less than 10 rep. – Rob Avery IV Nov 21 '12 at 14:17
Answered for you with a possible reason – Journeyman Geek Nov 21 '12 at 14:24
up vote 0 down vote accepted

Apparently something went wrong with the install, and I'm guessing from most of the sources I've looked at that your path location was wrong this can also happen if for some reason you have more than one version of java, and the 'wrong' version was earlier in the path. Reinstalling set the path location to the correct location and everything works fine.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .