Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Word is imposing a line break and causing a superscript (which is part of a unit) to be split across 2 lines; e.g.

...foo bar 30 ms ⁻  
² foo bar...

which obviously looks a little wrong! I've tried selecting / deselecting the orphan controls / keep with next / keep lines together in the paragraph options box. Is the only way round it to manually put in a Ctrl + Enter or is there a more proper way to solve the issue?

share|improve this question
    
@martineau Apologies. What don't you understand? –  ChrisW Nov 21 '12 at 19:26
    
@martinau sorry; I sometimes forget other peoples' knowledge on science notation isn't post-high school! ms^-2 is equivalent to 'metres per second squared' and is the unit of acceleration. A superscript - is the standard way to denote 'per' (hence the mathematical way of writing 'metres per second' - the unit of speed - is ms^-1, rather than m/s). I'm not doing anything rather than writing a normal piece of text in a normal paragraph. There shouldn't be a line break inbetween the superscript - and the superscript 2-all 5 characters of the unit (ms -2) should be on the same line –  ChrisW Nov 21 '12 at 19:36
    
@martineau no - the superscript - is as important (ms^2 is a different unit to ms^-2) :) I type in foo bar 30 ms-2 near the end of a line (when the paragraph is justified) - this makes the 2 go onto the next line; I then make the -2 superscript and the result is that the 2 is still orphaned on the next line. Perhaps Word thinks that my - means I allow a line-break because it's a hyphen? –  ChrisW Nov 21 '12 at 19:54
    
@martineau - I've sorted the problem :) see my self-answer –  ChrisW Nov 21 '12 at 19:59

2 Answers 2

up vote 3 down vote accepted

Use one of the following methods:

1) Instead of typing the common Ascii hyphen (-), enter the real MINUS SIGN U+2212 (−), e.g. by typing 2212 Alt X. The result is a more correct symbol, which is more clearly recognized as a sign, and it additionally disallows line break after it. The common Ascii hyphen is generally treated as allowing a line break after it, even when no space intervenes.

2) Instead of typing the superscript as normal characters and then using the superscript command in Word, use superscript characters: U+2078 SUPERSCRIPT MINUS followed by U+00B2 SUPERSCRIPT TWO. You can enter them e.g. by using the Alt X method (207B Alt X B2 Alt X). This is better than method 1, since you are using superscript symbols designed by a typographer, not reduced-size raised versions of normal characters, which is what the Word superscript command really does.

3) Enter the equation mode and use the exponent notation there. When you enter -2 (with common Ascii hyphen) as the exponent, Word automagically implements it properly. A minor problem with this is that you need to change the base “m” from italic to normal, as the equation mode by default italicizes letters. A major problem is that the mode uses the Cambria Math font, which pretty much means that you need to use Cambria (or Cambria Math) as the copy text font, to avoid typographic mismatch. But if you have more complicated expressions, that’s normally the best way to go (in Word 2007 or newer at least).

share|improve this answer
    
Regarding the third option, you simply write "ms"^-2 (literally, with the quotes) in the formula box. The quotes will make ms non-italic. Also, to change the font from Cambria Math to the body matter font of the rest of the document, simply select ms and change the font! –  Andreas Rejbrand Nov 22 '12 at 12:44
1  
@AndreasRejbrand, thanks for the quotes tip! Re fonts, the problem here is that it appears to be impossible to change the font of the superscript, and a mismatch between normal characters and superscripts is disturbing. –  Jukka K. Korpela Nov 22 '12 at 14:17

The discussion with @martineau made me wonder if the hyphen was having an effect - it was. By using a non-breaking hyphen (Ctrl + Shift + -) I got the desired result

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.