Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new HP Pavilion HPE h9-1130 Phoenix Desktop with Windows 7 64-bit pre-installed. I would like to dual boot with the latest stable release of Ubuntu, version 12.04.1 LTS. I followed the steps in this tutorial but am stuck.

The initial HDD composition was as follows: SYSTEM 100MB, OS (C:) 1.81TB, and HP RECOVERY (D:) 17.1GB. I ran GParted through my Ubuntu CD and created an extended partition comprised of the root (150GB ext4), linux-swap (8GB swap), and home (92GB ext4). GParted recognized all pre-existing partitions as well as the newly created ones. However, when I run the Ubuntu Installer there are no partitions listed to select for installation and it does not automatically detect that Windows 7 is installed as I presume it should.

When I rebooted the machine Windows automatically ran chkdsk and everything appeared to be okay; Windows works fine. I tried running sudo fixparts /dev/sda in Ubuntu but everything looked fine as well. Any suggestions?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Note that FixParts doesn't report certain types of problems, but silently corrects them in memory. If this happens, you might need to run FixParts and type w at its menu to save your "changes," even if you didn't make any explicit changes.

If that doesn't help, the most likely explanation is that your disk has been used in a RAID array or you've got RAID features enabled in your firmware. You can check your firmware options and disable RAID if it's enabled. If that doesn't help, you could try using the Linux dmraid utility to erase old RAID metadata that may be causing problems:

sudo dmraid -E /dev/sda

Be careful, though; if your system is actually using RAID, this could be quite destructive!

share|improve this answer
    
I did type w in FixParts. You're correct, I do have RAID enabled. However, I am not willing to take the risks involved with deleting RAID metadata or disabling RAID albeit temporarily. Is there another alternative? –  railser Nov 23 '12 at 16:08
    
Just to clarify - what exactly are the risks involved in deleting the metadata or disabling RAID? Is it possible that this would create kernal problems and prevent me from using the computer again? –  railser Nov 23 '12 at 16:20
    
If you're actually using RAID -- that is, if you've got two disks with RAID enabled -- then you need to figure out how to fully activate support for your motherboard-based software RAID in Ubuntu rather than delete the RAID data as I initially suggested. This probably involves setting up the dmraid utility, but I'm not very familiar with the process. OTOH, if you've got just one hard disk, removing the RAID metadata and deleting the dmraid package is almost certainly the appropriate thing to do. Always keep good backups before messing with disks on this level, though! –  Rod Smith Nov 23 '12 at 19:17
    
Okay, thanks for the information. I'll try to figure it out but I am inexperienced with RAID. –  railser Nov 26 '12 at 15:35

After a week fight with the same problem, I realized that I have a program called Paragon Partition Manager. It has an option when you right click outside the partitions, to convert the hard drive from GPT to Basic. I now have Windows 7 and Ubuntu 14.04 both working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.