Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm developing a full screen app that I just launched that has apparently completely stolen the keyboard to the point where nothing can get me out. Not command-option-esc, not command-option-shift-esc, not command-tab, nothing. Moving the mouse to the edge of the screen doesn't bring anything up. Can someone help me before I just force shutdown?

share|improve this question
up vote 2 down vote accepted

If you have an Apple keyboard, you could try using one of the function keys that brings up Mission Control or shows the desktop — typically F3 or F4, but it may vary depending on the vintage of keyboard (it may be fn-F3/F4/etc. depending on your system preferences).

If that doesn't work, try bringing up the shutdown dialog with either the power button or ctrl-eject. That might be enough to release keyboard control and allow you to command-tab out. At the very least you should be able to perform a clean shut down.

Finally, if you happen to have Remote Login enabled (in Sharing Preferences), you could SSH in from another machine and kill the errant process.

share|improve this answer
    
Thanks, but I tried all of that. Nothing worked. I've already forced reboot. But I'm going to set up ssh so I can kill it in future. Thanks. – Linuxios Nov 22 '12 at 0:33
    
Was your app still clearly running? If the power button didn't work, it may be that your system hard locked (which is unusual for a Mac, typically it kernel panics if fully locked up, but it's possible). – robmathers Nov 22 '12 at 0:35
    
I still don't understand how a cocoa app took such full keyboard control. It's not a bad thing, as it is an education app for which control is a good thing, I just have to add a get out of fullscreen option. – Linuxios Nov 22 '12 at 0:35
    
nope. The mouse still moved, and pandora still played. I wouldn't call that a hard lock. – Linuxios Nov 22 '12 at 0:35
    
That is strange. My Cocoa knowledge is mostly limited to iOS, so I can't offer any help there, but perhaps run your full-screen code past StackOverflow to check for anything wonky. – robmathers Nov 22 '12 at 0:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .