Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to compile FFmpeg 1.0 "Angel" with following configure :

./configure  --enable-gpl --enable-encoder=mpeg2video  --enable-version3 /
             --soname-prefix="/pc/temp/myproject/"

then compilation return following error :

Unknown option "--soname-prefix".
See ./configure --help for available options.

and when i'm running ffmpeg/configure --help command. "--soname-prefix" opetion is not available in Standard options list but this option is available in FFmpeg 0.11.2 "Happiness"

Please help me and if any new options is introduce in latest FFMPEG 1.0

Thanks

share|improve this question
add comment

1 Answer

Can't find --soname-prefix in ./configure script for both versions 0.11.2 and 1.0. But I think, if this is an option to library path, you need --extra-ldflags="-L/your/libs"

share|improve this answer
    
you known diff between --soname-prefix and --extra-ldflags .--soname-prefix if available in all lower version –  ρяσѕρєя K Nov 22 '12 at 9:29
    
I never used --soname-prefix, but i guess it's not a path definition, but prefix to library names (really don't know)? Which version is last you know, it is using this option? –  week Nov 22 '12 at 9:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.