Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Nothing happens when I click on a URL outside of a browser. Chrome is my default browser but it does not do anything if I click on a link in e.g. Skype. What can cause this?


HKEY_CLASSES_ROOT\http
    (Default)    REG_SZ    URL:HyperText Transfer Protocol
    AppUserModelID    REG_SZ    Microsoft.InternetExplorer.Default
    EditFlags    REG_DWORD    0x2
    FriendlyTypeName    REG_SZ    @C:\Windows\System32\ieframe.dll,-903
    Source Filter    REG_SZ    {E436EBB6-524F-11CE-9F53-0020AF0BA770}
    URL Protocol    REG_SZ
    WebNavigableCLSID    REG_SZ    {ae90e550-0443-47fb-a001-4875648d4ed3}

HKEY_CLASSES_ROOT\http\DefaultIcon
    (Default)    REG_SZ    C:\Program Files (x86)\Google\Chrome\Application\chrome.exe,0

HKEY_CLASSES_ROOT\http\Extensions
    .ASF    REG_SZ    {187463A0-5BB7-11D3-ACBE-0080C75E246E}
    .WM    REG_SZ    {187463A0-5BB7-11D3-ACBE-0080C75E246E}
    .WMA    REG_SZ    {187463A0-5BB7-11D3-ACBE-0080C75E246E}
    .WMV    REG_SZ    {187463A0-5BB7-11D3-ACBE-0080C75E246E}

HKEY_CLASSES_ROOT\http\shell
    (Default)    REG_SZ    open

HKEY_CLASSES_ROOT\http\shell\open

HKEY_CLASSES_ROOT\http\shell\open\command
    (Default)    REG_SZ    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" -- "%1"

HKEY_CLASSES_ROOT\http\shell\open\ddeexec
    (Default)    REG_SZ
    NoActivateHandler    REG_SZ

HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Application
    (Default)    REG_SZ    IExplore

HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Topic
    (Default)    REG_SZ    WWW_OpenURL
share|improve this question
    
Post here values from registry key HKEY_CLASSES_ROOT\http, you may use this command in cmd.exe, reg query HKCR\http /s. – week Nov 22 '12 at 11:12
up vote 0 down vote accepted

In the registry Chrome was set properly as the default browser for ftp, http and https, however in Control Panel/Default Programs it was "Unknown application" (or something like that). Setting Firefox and then Chrome back as the default didn't solved it so I had to reinstall Chrome. That worked.


If you are encountering a problem similar to this, the following question has a great answer related to this topic: How do I change my default browser to an unlisted program in Windows 7?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .