Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using the Alt code for the ellipsis, 8230, for some time now, in several applications. A few days ago it stopped working, and & is displayed instead of when pressing Alt+8+2+3+0 (on numpad). This happened both on my desktop and on my laptop (where I use it with Fn). Both run on 64bit-Win-7 with code page 850, and both might have recently updated Windows and Opera 12.

What could be the reason this input method got disabled, and how do I switch it back?

By the way, I just found out that Alt+0+1+3+3 does work. Also I found out that Alt+8+2+3+0 still works in WordPad or MsWord10, but neither in Opera nor Notepad++ - there the character code is translated modulus 256 before insertion.

share|improve this question

4 Answers 4

As far as I know, the Alt nnnn (nnnn decimal > 255) method is a RichEdit feature and therefore works on selected programs only, such as WordPad and MS Word. In other programs, the number entered, nnnn, is reduced modulo 256 to yield a number in the range 0...255, interpreted according to the code page in use.

Cf. to Insert Unicode characters via the keyboard? which describes some alternative methods. Unfortunately, the Alt + xxxx (xxxx hexadecimal; e.g., Alt + 2026 for “…” ) method is apparently disabled by default, and you need to modify Windows registry to allow it. In addition to the UnicodeInput utility, there is also Unicode Input by Name, but these methods are not quite as convenient for fast typing as Alt methods.

share|improve this answer
    
Thanks, that seems to be the right direction. Apparently Opera 12 has dropped this RichEdit feature. Can I re-enable that manually somehow or would I need to write a bug report? –  Bergi Nov 22 '12 at 19:05
    
+1 Your remark that in other programs, the character value is mod 256 is exactly the behavior I observed in Notepad. –  Nicole Hamilton Nov 22 '12 at 19:08

Alt codes and unicode characters are only vaguely related, and (for the most part) it's up to each application to determine how to deal with them, so it can be different between apps, versions of apps and such.

Essentially it's about character encoding and Code Pages, rather than fonts or user input.

Alt codes for ASCII are only 0-255 (8-bit code page). Many programs (and OS's) deal with larger numbers inputted by the user by wrapping at 256.

256 = 0, 257 = 1, etc.

So entering ALT+8230, is actually equivalent to typing ALT+38 (8230 / 256 = 32.1484375. 256 * 32 = 8192. 8230 - 8192 = 38), which is the ASCII character "&" -- unless the program intercepts it and replaces it with 'proper' Unicode codes, or by using a different code page (ie: Unicode), as MS Word, and newer WordPad versions do, for example.

Windows uses an extended version of the MSDOS 8-bit Codepage (850) called the "Windows-1252" code page (for English languages anyway). But it only uses this for legacy parts of the OS that don't fully support the Unicode code pages.

These are the reasons why you can easily see different results in different OS's and applications, as well as within different parts of Windows itself.

It's a confusing issue to say the least. :)

I'm pretty sure Alt-0133 is the "official" Windows extended ALT code for the ellipsis (in the Windows code page), so you'll probably have more consistent luck using it.

Here's some more related info.

share|improve this answer
    
Thanks for the informative link. I already saw there are confusing differences when searching for the issue :-) –  Bergi Nov 22 '12 at 19:35

U+8230 isn’t the ellipsis, it’s the Han Character warship: . I don’t know why you were ever getting an ellipsis with that code, but 133 is indeed the correct code-point for it.

Where exactly where you seeing an ellipsis for 8230? Perhaps it was a bug in Opera that has been fixed since the last update. If it was in “several applications”, then perhaps you had a bug in your font or keyboard layout/regional setting or something (nothing obvious or rational comes to mind, so it must have been a bug as opposed to a legitimate setting).

If (for some reason) you really want/need to use an incorrect code-point for it instead of using the correct one, you can use can use something like Authotkey to create a script that accepts a chord or sequence and outputs what you want.

Are you sure that you were able to enter Alt+Numpad-8+Numpad-0+Numpad-2+Numpad-3? Though some programs may independently support it, Windows does not accept high Unicode code-points like that by default. You can use hex-entry though: Alt+Numpad-++2+0+2+6.

share|improve this answer
    
8230 is decimal for hex 2026 which is indeed the ellipsis. fileformat.info/info/unicode/char/2026/index.htm Alt+8230 works in some apps (e.g., Outlook new message) but not others (e.g., Notepad) for me on Win7 x64. –  Nicole Hamilton Nov 22 '12 at 18:58
    
8230 is the decimal character code of U+2026 (Ellipsis). I never used the + or 0 prefix, I just held down Alt and entered a four-digit decimal charcode. As said in the question, this still works well in Word. –  Bergi Nov 22 '12 at 18:59
    
Yes, I'm sure it worked, but I guess it did only in my favourite applications :-/ Hex entry is currently not enabled and yields , so I'll stick to 0133 –  Bergi Nov 22 '12 at 19:32
    
> Hex entry is currently not enabled Maybe not, but you can enable it for convenience because like I said, Windows does not accept 8000+ code-points (in decimal) by default. Using hex-entry is a Windows setting, so it works in all applications (at least all that support Unicode edit boxes). –  Synetech Nov 22 '12 at 19:38

Maybe the current font does not support such upper Unicode characters, change the font to 'Arial' and try again.

When I test this in WordPad, ALT+8+2+3+0 works for Arial, but not for for some other fonts.

share|improve this answer
    
No, the fonts do support displaying them. Also I don't think a font is allowed to affect the input method. –  Bergi Nov 22 '12 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.