Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi I was trying to install Windows XP on a Samsung SENS 145 plus Notebook. It does not have a cd drive and I already managed to format it and semi install Windows XP, so now it does not even boot up either. This is what I did:

Since it supports USB booting, I first made a bootable USB of Windows XP (Korean version; SP2 I think, may be SP3) using Novicorp WinToFlash. It managed to boot up at first and I was able to format the C drive and get Windows install to start up. It took forever to copy all the files from the USB and after the first reboot, before installation started, I cancelled the reboot from Windows install, went to BIOS and changed the boot device priority from USB to internal hard drive. But now on bootup it showed me a list with two options for booting Windows XP (much like in the case of a multi OS system) so I assumed that I had formatted drive D by mistake and installed XP there, instead of on C drive. Anyway, I chose one of them and it continued my Windows installation. I got the blue installation screen that shows ads about Windows XP on the right frame and estimated remaining time on the left. However, after completing the process, after the first reboot, instead of showing the Windows XP logo, it says \system32\hall.dll is missing (or corrupted I'm not sure, I needed to install the Korean version of Windows and I could not exactly read the error message, however it was one that I have already seen in an English version installation, and I am sure it says either missing or corrupted).

The problem is, now it shows the same error again when I try to reboot it from the USB drive as well. I tried to boot a portable version of Linux I made in another USB, but the computer does not boot up from that USB, and it shows hal.dll error when I try to boot it using the Windows XP installation USB I made, as well as when I try to boot it from the hard drive, where I suppose Win XP is now semi-installed. So now I can't get the computer to start up at all, except going to the BIOS.

What else can I try to solve this?

Also, would it be possible to install XP on this computer by connecting it to another one running Windows 7 ultimate, through the Ethernet card? That is, network just the two computers together, then install Windows XP on the notebook from the desktop running Windows 7? Please help, I'm running out of ideas on this one. If Korean version of Windows XP is the problem then I am willing to install English version as well. (but I need to make sure if that is the real cause of the problem)

share|improve this question
1  
Are you sure the Linux LiveUSB was created properly? Can you test it on another PC? If it works, there's no reason you cannot boot your laptop as well from it, irrespective of a botched Windows install. Also make sure you set the boot order properly in your BIOS. If you don't do this it will simply skip the USB and attempt to boot straight from your HDD, which will obviously fail due to the broken Windows installation. –  Karan Nov 23 '12 at 21:27
    
I have been using that USB in multiple computers since a long time ago so I know it was created properly. In fact I booted this computer using my multiboot pendrive and tried to install windows from FreeDOS but I couldn't get the installation to start. Then I made a bootable Windows XP installation USB. It got the installation program to start but it got botched and after that the computer did not boot from my USB –  user13267 Nov 25 '12 at 12:29
add comment

1 Answer

I have fixed the hal.dll error It was because of configuration problems in the boot.ini file As I mentioned I had used Navicorp Win2Flash to make a bootable Win XP installer USB. Since the Windows installer program assumes it is installing from CD while it is not a true CD drive install, the boot.ini file that is created does not correctly point towards Windows loader (ntldr I think). Moreover this notebook had a hidden partition above the C drive partition for storing an image for the samsung recovery software, but there was no image or recovery software installed, which complicated the matter.

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Here 'partition(1)' had to be changed to 2, and we have to make sure rdisk is set to (0) if it was set to (1) (rdisk might be set to (1) by the recovery console if we go to it through the bootable USB and use the boot.ini file creator of the recovery console)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.