Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can connect to the wireless network at home using a PC. It uses WPA/WPA2 and the first thing I need to input when I try to connect is a security pin, once I do that and I get a response, I can type the WEP key as well and connect.

When I try to connect using a Mac, the pin option nevers shows up.

I tried to configure going though: System Preferences > Network > AirPort > Advanced From the there selected the network and clicked the pencil icon and for the Security option I've picked WPA2 Personal, but there is no prompt for the initial security key. When I type the wep key directly I get an IP that is not working 169.etc.etc.etc. instead of 192.168.etc.etc.

What option do I need to choose to connect ?

share|improve this question
up vote 1 down vote accepted

the equivalent of the 'PIN' on windows is DHCP Client ID in TCP/IP settings (Network Advanced settings)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .