Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When logging in, stackexchange sites offer SE, Google, Facebook, and Yahoo logins, using 4 buttons. However, on my desktop, when I hover over those buttons, they do not display the yellow border and do not react to clicks. This only happens on my desktop machine, and only on IE 10 (I have three different machines running windows 8, and only the one exhibits this behavior). Since there is no way of reinstalling IE, I don't know what to do. Reseting IE doesn't work. Could it be a cookie issue? I tried deleting all of my history, but that didn't resolve the problem.

share|improve this question
Check your internet settings on IE10, check to see if javascript is enabled, because I think those buttons are not "links" they're most likely javascript objects. – Brutick Nov 23 '12 at 18:32
The objects wouldn't even show up when JS was disabled ;) Either way, I checked, it's enabled. – Goran_Mandic Nov 24 '12 at 14:54

I'm running Windows 8 on both a desktop, and on a Microsoft Surface device. I also use Google to log into Stack Exchange. I can tell you that it works for me on both devices. I've tried both desktop IE and "metro" IE and they both work.

Maybe it is your IE settings? On the desktop version of IE press F12 - you should see a window pop up and at the top it should have some mode indicators. Note that the mode is site specific, so you may want to do this when on Stack Exchange. In any case, the indicators should say IE 10, standards mode. If not, that may be your problem. You can change the mode by clicking on the indicators.

share|improve this answer
I think you're on the right track. This might help . – Goran_Mandic Nov 24 '12 at 14:52
So, in line 7, character 116 the jquerry error occurs. The line says: window.localStorage.getItem(this.localKey);a&&(this.prefs=$.parseJSON(a))}retur‌​n this.prefs},setPref:function(a,b){if(window.localStorage){this.prefs[a]=b;try{wi‌​ndow.localStorage.setItem(this.localKey,stringify(this.prefs))}catch(c){}}},init:‌​function(a,b,c,d){openid.img_path=c;openid.use_affiliate_post=d;$("body").css("cu‌​rsor","default");$("#openid_submit").css("cursor","default");$("input[type=submit‌​]").removeAttr("disabled");this.input_id=a;$("#openid_choice").show();if(b){a=b.s‌​plit(",");for(b= – Goran_Mandic Nov 24 '12 at 14:56
Can you try using a different browser, such as FF or Chrome? If it does happen there as well, then maybe you have some other issue. – chue x Nov 24 '12 at 16:21
That's really not a solution. Call me crazy, but IE 10 actually seems to work a bit faster than Chrome and FF on Win8. This is just a subjective perception of mine, but it definitely has a smaller memory footprint. I am using Chrome solely for StackExchange now. In other words, this issue occurs only on IE, and only on one machine:\ – Goran_Mandic Nov 24 '12 at 16:50
Don't get me wrong, I personally prefer IE. I just wanted to rule out something like anti-virus which sometimes does some weird things. – chue x Nov 24 '12 at 17:12
up vote 0 down vote accepted

I've pinpointed the error from my comment above, and it seem that this line


was having trouble accessing the session storage, because I wasn't running IE with administrator privileges. Once I did, the login buttons worked. While this doesn't really tell the story of WHY IE behaves this way without admin privileges, it solves my StackExchange login and Google+ notification problem (I had this problem too).

EDIT: It was the enhanced protected mode setting which the Metro app has enabled by default. This setting enables the XSS filter which verifies the credibility of the site you want to log in to.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .