Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like high DPI enabled for most of the applications that I use on my 14" 1920x1080 laptop, except for a few like Visual Studio that benefits from the extra space. However, setting "disable high DPI" in compatibility does nothing. I am using Windows 8.

share|improve this question
    
Synetech edited this question. I can't find a way to comment on his revision or to send him a message, so I'll post the reasoning here: The question is specific to VS 2012 (and perhaps other applications using particular frameworks eg WPF) where regular DPI compatability setting does not work. Also, it's almost certainly not specific to Windows 8, although I haven't tested it on 7/Vista. –  Aleksandr Dubinsky Nov 26 '12 at 19:04
    
I removed the Windows tag since it should only be used if it effects ALL versions of Windows since your using Windows 8 only that tag applies to you. –  Ramhound Nov 26 '12 at 20:26

3 Answers 3

up vote 2 down vote accepted

i asked Chris Jackson, the Microsoft AppCompat guy; there is no way to do this.

We don’t have such an ability, the scaled mode is what we have to handle those situations. Yes, there clearly are some things that are suboptimal about how we do that (I hate the fuzzies too), but it’s hard to get a second fix approved which technically solves the same thing since that means that engineer isn't doing something else to make the world a better place.

i also asked nearly the same thing here.

share|improve this answer
    
Thank you for your reply. Hearing this, and hearing other comments re C# development, one gets the impression that Microsoft has no money and barely has a dozen people working for it. There is no attention to detail. Little things never get fixed. All in the name of "we don't have the resources." How inefficient is MS? Anyway, this is a bit of a big deal since I paid top dollar for the display that only benefits a few screen-hungry apps. I've turned off High DPI entirely, but why should all the other apps be tiny? Is per-app DPI so hard? Chris implies the fix is easy, but "forbidden". –  Aleksandr Dubinsky Nov 26 '12 at 19:10
    
@AleksandrDubinsky - If you get that impression then I don't know what your hearing but its anything Microsoft is doing. There has been hundreds of improvements between .NET 4.0 and .NET 4.5. –  Ramhound Nov 26 '12 at 20:27
    
@Rahmound Eric Lippert answered an SO question of why C# can't infer generic types for constructors with something like, "there's no real problem, it'd be a lot like inferring them for methods. But we have limited budgets [--yeah right]. And, btw, consistency of the language is a low priority." Other examples in C# is generic type constraints for Enums and delegates, which are likewise dead-simple to implement. Or, eg, Word/Excel 2010 still has bizarre Alt+Tab behavior because noone bothered to rewrite the hacks around old MDI. Or all of Win8 that isn't Metro. The list goes on, plus this reply –  Aleksandr Dubinsky Nov 29 '12 at 15:04
    
@Rahmound MS's philosophy is simply this: adding new features is great. Improving the things that are already written is "a waste of our precious, miniscule resources" even when there aren't any more features to add. That is incongruent with how much money MS has, and really takes its toll when the timescale is decades. Half of Word/Excel's dialogs predate Office 95! Plus the multi-window madness. Visual Studio is a pain to use having discovered Netbeans. VS's GUI was ENTIRELY rewritten in WPF for 2010, and NOTHING OLD WAS IMPROVED. Stasis. Wonderful, comforting stasis. –  Aleksandr Dubinsky Nov 29 '12 at 15:15
    
MS is a large corp. Which means, in America, they have a large employee base but very few people that actually work. Everyone wants to work for M$, but no one does it for the love of coding, or very few do, anymore. –  Motes Apr 20 at 15:29

This is absolutely possible. I was using the "compatibility" settings on executables to do it but for some reason that's not available for VS. However the equivalent registry key works just fine. The key is HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers and you just have to add a string value "~ HIGHDPIAWARE" (same as ticking that box in the compatibility tab of the executable's properties). Or you can just run this:

reg add "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /v "full path to Executable" /t REG_SZ /d "~ HIGHDPIAWARE"

share|improve this answer
1  
Welcome to SU! Link-only answers are considered a no-no due to possible future link-rot. Please edit your answer and include pertinent information directly, and include the link as a source reference. –  Ƭᴇcʜιᴇ007 Dec 23 '13 at 16:54
    
Thanks for the tip ;) updated the answer. –  futuresandwich Dec 23 '13 at 20:24
    
This will work specifically for VS? I don't see what identifies the exe –  Aleksandr Dubinsky Dec 23 '13 at 21:37
    
Yes sorry Aleksandr SU's markup had removed the placeholder. Check the answer again. –  futuresandwich Dec 24 '13 at 22:51

THIS IS POSSIBLE

I tried this on my Windows 8 and it works perfectly:

  1. Go to your Visual Studio Shortcut/app launcher
  2. Right Click and Troubleshoot Compatibility
  3. Continue Troubleshooting Program
  4. Troubleshoot Program
  5. Tick: Program opens but doesn't display correctly
  6. Test Program..
  7. Yes, Save Changes

You are all set!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.