Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

PDF files have suddenly started to open within the browser windows of Firefox 17. The PDF files are being displayed with the Adobe Acrobat plugin, which is odd, since I have explicitly disabled the Adobe Acrobat plugin in Firefox.

I would like for Firefox to show the download prompt when opening a PDF file, instead.

I have disabled the Adobe Acrobat plugin and I have made sure that PDF files are set to "Always Ask" in the Options dialog.

For good measure, I've also tried disabling all plugins and extensions, and associating all file types to "Always Ask", but to no avail.

So why is Firefox 17 suddenly ignoring these settings?

share|improve this question
    
I would suggest using a PDF reader other than Acrobat Reader. I'm using Foxit Reader and I currently do not have this association issue with Firefox 17. I can click on any PDF file in Windows Explorer and they open within Foxit Reader. –  Isxek Nov 24 '12 at 9:22
    
Looks to be an Adobe plugin related bug, since I have FF 17.0 as well and neither Foxit nor any other PDF reader with a FF plugin is causing this issue. –  Karan Nov 24 '12 at 19:07

7 Answers 7

This is not an Acrobat problem. Firefox 17 handles PDF files natively without using a plugin and by default PDF files now open in the Firefox PDF preview window.

To change this, go to menu Tools -> Options, click on 'Applications' and scroll down to "Portable Document Format (PDF)" (that begins with 'P', so go way past the 'Acrobat ' files at the top)).

To the right you have some options. By default it is set to 'Preview in Firefox'. Change this to something else; 'Always ask' or, if you prefer the Acrobat plugin 'Use Acrobat Reader', choose the Acrobat plugin option (this requires Acrobat Reader to be installed; if Foxit Reader is installed it will instead show Use Foxit Reader, Best Viewer for Ev...)

share|improve this answer
2  
That's the one. –  Austin ''Danger'' Powers Mar 1 '13 at 22:09
    
This is the correct answer. –  Peter Mortensen Apr 8 '13 at 18:34

open acrobat, and go to Edit -> Preferences -> Internet. Uncheck the box at the top that says "Display PDF in browser". That should do it, whether you have the plugin installed or not.

share|improve this answer
    
As per your suggestion, I have unchecked that preference in Adobe Acrobat, but Firefox still loads PDF files using the Adobe Acrobat plugin. –  root Nov 23 '12 at 23:11

There is a several month old comment on a 2011 Firefox bug report noting that Aurora 17 (early Firefox alpha/beta version) that states they were experiencing this issue. It is possible that it went un-noticed and made it into the release.

Navigate to https://www.mozilla.org/en-US/plugincheck/. Disabled plugins shouldn't appear in this list. If Acrobat is shown, then there is a bug.

You can also navigate to about:plugins and check if the Adobe Acrobat plugin is still appearing there.

Unfortunately as far as I can tell there is no way to fix the issue right now, so you may have to either wait for a patch or downgrade to Firefox 16.0.2.

Also remember you must restart Firefox after changing any plugin settings, they won't take effect until after the browser restart.

share|improve this answer

To work around this Firefox bug for now, you can delete the plugin from the hard drive. this article explains how to do it: http://www.ghacks.net/2010/10/02/how-to-remove-plugins-from-firefox/

The basic idea is to look at about:plugins to find the full path of the plugin files, and then manually delete them. To see full paths to plugins, go to about:config first, to change the preference plugin.expose_full_path to true

This worked for me on Win 7 64-bit with FF 17.0.1

share|improve this answer
    
The Adobe Reader plugin is one of the most persistent. I actually found the plugin DLL in 3 places on my system: 1) C:\Program Files (x86)\Adobe\Reader 10.0\Reader\Browser 2) C:\Program Files (x86)\Adobe\Reader 10.0\Reader\AIR 3) C:\Program Files (x86)\Mozilla Firefox\plugins –  Percy Blanket Dec 5 '12 at 20:31

It sounds like you have the same issue I had. Navigate to: https://www.mozilla.org/en-US/plugincheck/ if the disabled Acrobat plugin is shown in the list this is caused by a unfixed bug in Firefox 17 and is retained in version 17.0.1. For more information on the bug read the reply by William Lawn Stewart.

Alight, here's how I corrected the issue:

  1. Open Acrobat outside of Firefox (not the in browser version).
  2. Navigate to Edit > Preferences > Internet. Uncheck "Display PDF in browser".
  3. In Firefox open Add-ons Manager (Ctrl+Shift+A).
  4. Navigate to Plugins.
  5. Enable the Acrobat plugin.
  6. Disable the Acrobat plugin.

You may need to restart Firefox to fully disable the plugin.

Credit to Frank Thomas for steps 1 and 2.

share|improve this answer
    
That page will tell you if any of your plugins is out of date. But it won't tell you if a plugin is screwing up. And a bad plugin isn't even the issue in this case because the question is "how do I not use the plugin?" –  Isaac Rabinovitch Dec 12 '12 at 23:25

This seems to be an issue with FF not "honouring" disabled plugins after an upgrade.

Re-enable the Acrobat plugin, restart FF, then disable the plugin again. The plugin should now be properly disabled.

You my want to do the same with other plugins - especially if they are supposed to be disabled but show up in the plugincheck page.

share|improve this answer

Note that in the FF Options under Applications in addition to the PDF (under "P") there are several Adobe PDF-related items (under "A"). I don't recall seeing these before. Regular Adobe PDF items were marked "Always Ask" which is how I had set it, but the ones I believe are new, such as Acrobat Forms and Acrobat XML files were set (I believe by default) to preview in FF.

I have changed all to "Always Ask" and that appears to have stopped automatically opening any PDF documents.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.