Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By an accident i uninstalled my Connect manager (ZTE). but when i re-install it the virtual CD drive is detected but it does not detect the drivers. When i direct to the folder containing the relevant drivers(.sys files) still it doesnt detect.

Then i tried a modem of a different brand Huawei the same problem presists As i understand it is not a device(brand) driver specific issue as it does not detect modem(dongles) of any brand. when i plugged in a different USB device(a pen drive) the driver is detected and it works perfectly.

Please help me with the issue i have tried system restore but it doesnt work. I want a repair that works without re-installing windows

[Edit] Uninstalling drivers/ software and reinstalling doesnt work.
the issue does not deal with the registry

share|improve this question
1  
Unplug the modems/dongles, uninstall all software/drivers, restart, use USB Oblivion, restart once more and try any one dongle. Let us know if it worked. – Karan Nov 24 '12 at 23:10
    
Tried it didnt work.. I am sure that the issue does not deal with the registry as i have tried your method and system restore in an earlier instance – Shenal Silva Nov 25 '12 at 4:13
    
If you have now all the software installed as before you uninstalled it, you may be able to rollback to a system restore point in which everything worked correctly. – harrymc Dec 13 '12 at 19:03
    
Tried it mate it didn't work – Shenal Silva Dec 13 '12 at 20:56
    
It has to work, unless : (1) should rollback further, or (2) hardware problem. – harrymc Dec 14 '12 at 8:14
up vote 1 down vote accepted

As you say that it is not driver or hardware, that leaves only Windows. However, as you have not specified the modem's hardware connection, hardware still remains a possibility (for USB it is easy enough to check if the socket works by using an external disk or key).

For fixing Windows without a complete reinstallation, I can suggest :

  • Windows Update including optional updates
  • sfc /scannow
  • Extensive virus scans by several well-known anti-virus products (just to be sure)
  • (The method that worked for this problem) If all fails : repair install, which only refreshes Windows and without doing a complete installation, so leaving intact all installed applications (you need for that an installation DVD of the same service-pack level as your current installation).

Make sure you have complete backups before starting.

share|improve this answer
    
Well i am going to try your suggestions. what info do you require of the modem's hardware connection?. It is a ZTE MF110 usb modem. and all the other modems that i have tried are also usb modems – Shenal Silva Dec 16 '12 at 9:23
    
Have you checked that this usb socket works? – harrymc Dec 16 '12 at 11:19
    
If system restore and even repair install didn't manage to get modems working on your computer, the only suggestion I have left is to format the disk using slow format and reinstall Windows and everything from scratch. – harrymc Dec 20 '12 at 15:16
    
the repair install method worked thank you :) – Shenal Silva Jan 7 '13 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .