Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have both Windows 7 and Kubuntu installed on a computer. They both have access to a NTFS partition. I don't know how that happened, but I now have a directory containing weird characters: Bases de données, on this partition. The proper name should be Bases de données. When I noticed this, I was running the Linux OS; (I am assuming that) the problem is that I tried renaming that file from there.

First of all, here is how the NTFS drive is mounted through /etc/fstab:

UUID=...  /data  ntfs-3g  rw,users,auto,noexec,uid=0,gid=0,fmask=0111,dmask=0  0  0

I cannot get to rename this particular file, which messes things up: in the command line, I got the following error:

mv: cannot move `Bases de données/' to `Bases de données': Input/output error

Dolphin gave me an error of the same spirit. But despite this error, the directory seems to be copied: I now end up with two directories: Bases de données and Bases de données.

In order to fix the issue, I booted on Windows, but I now have a problem removing the "duplicated" folder: I get the following error (I don't have enough reputation to upload an image directly, here is the screenshot):

Error 0x80070570: The file or directory is corrupted and unreadable.

I can still open the files within the directories without a problem. In an attempt to diagnose the problem, I did create a directory with the same name (with the é) in /tmp and tried renaming it, and this did not reproduce the symptom. Also, running ntfsfix did not solve the issue.

I would really appreciate some help to diagnose and fix this problem! Thanks!

share|improve this question
    
Try chkdsk /f? And may be Far Manager is able to rename/delete this folder. –  Maximus Nov 24 '12 at 11:57
    
I generally refrain from using the norwegian æ, ø, å and the whole Russian alphabet for filenames to avoid headaches. The answers provided in this entry on serverfault may help you –  Ярослав Рахматуллин Nov 24 '12 at 17:53
    
Indeed, chkdsk /f did solve my problem, thanks! Should have thought of that beforehand... –  piwi Nov 26 '12 at 7:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.