Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I have an odd issue that I can't quite figure out... I am running Windows 8 Enterprise on a Dell 6420 laptop. I have a Broadcom 802.11n wireless adapter. I am connected to an home router (Netgear WNDR3700) that is connected to the internet. It is a very simple home network setup. I am trying to stand-up a few VMs in Hyper-V and want the VMs to be able to access the internet over my wireless connection. I have found numerous examples of how to set this up using both External and Internal Virtual Switches but have yet to be able to get it to work on my machine.

I have narrowed the issue down to the fact that my host machine always loses internet connection when I bridge my wifi connection (both when it is bridged automatically by windows when I setup an external virtual switch bound to the wifi adapter or if I do it manually by creating an internal virtual switch, right click on it and my wifi network and select "Bridge Connections".) In both cases after the bridge is established, my host machine can no longer connect to the internet. I am not sure where to start with troubleshooting this problem. After the bridge is setup, an ipconfig shows all netowrk devices on the machine as "Media Disconnected". I do know that the wireless adapter is connected to the router b/c it shows the connection as active and full-strength.

The only thing I can possibly think of is that this machine also has the Cisco VPN client installed on it which installs a Cisco Virtual Network Adapter. Is it possible that this Cisco Virtual Adapter is causing me issues when I try to bridge? I saw some people had a similar issue with a VirtualBox virtual adapter when trying to share via Hyper-V.

Any thoughts or suggestions on how to troubleshoot?

share|improve this question
    
Does the Cisco VPN that you have installed support Windows 8? –  Ramhound Nov 24 '12 at 19:26
    
Yes, as far as I know, I do know that the 64-bit client I have installed works and I can use it to connect to external vpns. –  xinunix Nov 24 '12 at 20:18
add comment

3 Answers 3

Should have tried it before I ever posted, when all else fails, reboot!

Went back and setup an external virtual switch bound to my wireless card, as before lost internet after setup completed. This time I rebooted the machine, after reboot I had internet connection and now my VMs can access the bridged connection.

Once again thanks to the old 3-finger-salute, problem solved, crisis averted, town saved.

share|improve this answer
add comment

Without rebooting I managed to get it working

Open the network connections control panel

You'll see the virtual adapter setting has created a network bridge.

enter image description here

Right click on your Wi-Fi adapter (the one with the signal strength) and select Connect/Disconnect

Then you have to click the On switch that comes up in the sidebar and select your network. For some reason it was Off even though I was online before.

enter image description here

Everything then magically lit up and I was able to access the internet from within my Win XP VM immediately.

enter image description here

share|improve this answer
    
...although the next day I had to completely delete and re-add the virtual adapter even though nothing had changed apart from reconnecting to a different network and back again. but now it's somewhat more stable –  Simon Feb 24 at 1:55
add comment

I had the same issue. Following steps from this site solved the issue.

On VM

  1. Delete external switch from the virtual machine.
  2. Keep/create internal switch and use it with the virtual machine.

On network adapter

  1. Go to wifi network adapter. Right mouse click to open properties of the Wifi Adapter.
  2. On the sharing tab of the Properties window tick "Allow other network user to connect through this computer's internet connection"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.