Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In this question, I asked why the actual CPU frequency wasn't being reported in the performance tab of windows task manager. It turns out I had Virtualization turned on in the BIOS. When I disabled it in the bios, Task Manager shows the actual CPU frequency (I assume averaged over all cores).

So why can't or doesn't Task Manager report the CPU frequency when Virtualisation is turned on?

share|improve this question
    
Is it happen even if the Hyper-V is disabled? The Intel VT is active in my BIOS but the actual frequency still displayed when Hyper-V is off. Perhaps there are other software that utilize the same API, but in vanilla Windows 8 without Hyper-V, the frequency will still show up. Perhaps you can list some application that probably utilize such functionality? (VS 2012 for Windows Phone 8 is one of them) –  Martheen Cahya Paulo Dec 5 '12 at 2:01
    
I did install Hyper-V, so I guess it was taking over some API that Task Manager uses? I don't have any application that uses that, such as Android or Windows Phone development kits. –  kristianp Dec 5 '12 at 5:23
    
I presume it's the case. Better edit into your question that the actual cause is the Hyper-V activation, instead of merely turning on virtualization in BIOS –  Martheen Cahya Paulo Dec 5 '12 at 9:31

2 Answers 2

Headline: It is showing the actual CPU frequency.
Installing (not just running) Hyper-V on Windows 8 causes the CPU to run at 100% all the time. I guess Microsoft was running into issues with virtual machines (VMs) when the speed would fluctuate. One way to fix that, is to not let it fluctuate.
I travel quite a bit and I have to install (turn on under Windows Features) and uninstall Hyper-V depending on my needs.
I noticed that with Hyper-V installed, but not running (my VM was Shutdown) my battery life was less than 2 hours. I would usually get 6+ hours before installing the Hyper-V.
It is ashamed that I have to make the tradeoff of VM (with short battery life) or Battery Life (with no VM)... What's worse is it isn't a matter of just turning off the Hyper-V, then turning it back on. You need to do some work to setup your VM again.
This information was based on Windows 8.0 Pro running on a Lenovo X1 Carbon and many hours of experimenting. I've not tried this again on Windows 8.1 Pro on my Microsoft Surface Pro 2.
UPDATE: I did try this again on Windows 8.1 Surface Pro 2. Same results. I've not tried it on my Surface Pro 3 yet.

share|improve this answer

This is normal. Some power management options are disabled when the Hyper-V role is enabled.

At least on my system, the CPU is in fact clocking up and down as appropriate for the current load level; a utility such as CPU-Z confirms this. While sleep and hibernate remain available (at least on Windows 8.1 Pro, but not Windows Server 2008), you cannot limit the processor's clock rate, which would be useful on battery. CPU time used by Hyper-V is not accounted for in Task Manager, and host processes always have priority over Hyper-V guests; in other words, any process, even a low-priority process, will starve Hyper-V guests of CPU time if the host process saturates the CPU.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.