Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old (IBM) Thinkpad T42. It was pretty much useless running XP, so I decided to install linux. I first tried Puppy Linux, but eventually settled on Lubuntu. I couldn't run 12.10 because it requires PAE, which is not available on the Pentium M. I am now running only Lubuntu 12.04 (I didn't partition it or anything; I don't have XP anymore).

Everything is working fine, except for the wireless internet — which is a pretty big problem for me. Under XP, the internet worked. It still worked under Puppy... but now it's not working. The thinkpad sees my network, but is unable to connect.

This post: Wireless doesn't work with Windows 7 and Lubuntu 12.04 is similar, but doesn't help.

lshw -C network tells me that I have a "Cisco Aironet Wireless 802.11b" interface, and rfkill list all returns nothing...

On the network side: I have an dual band Apple Airport Extreme. Most of my [new] devices use the 5GHz signal, but the thinkpad is obviously seeing the 2.4GHz one.

Any help is appreciated — I would really like to get internet up on this computer.

Thanks!

share|improve this question

closed as not a real question by Ƭᴇcʜιᴇ007, TFM, 8088, Nifle, Synetech Nov 25 '12 at 18:12

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

    
Does Lubuntu have anything to do with the concept of a luser from the BOFH series? –  Ярослав Рахматуллин Nov 25 '12 at 15:39
2  
I believe it comes from LXDE + Ubuntu –  baum Nov 25 '12 at 15:41
    
You might be best off getting an Intel mini-PCI card from eBay. You might as get a wireless-G one, which will be faster (but make sure it is for your T42, as it has to be whitelisted in the BIOS). –  paradroid Nov 25 '12 at 15:51
    
Are you running the drivers through ndiswrapper or just whatever the system dubbed? –  nerdwaller Nov 25 '12 at 15:52
    
I don't have any drivers... I just realized that any drivers I may have had under XP/Puppy would have been erase when I formatted the HD :(. –  baum Nov 25 '12 at 15:54

1 Answer 1

I am taking a look through the Ubuntu forums, and it seems to be a relatively common issue with that card, so I bet we can get you there. Here is a well reviewed option:

Add the following lines to your /etc/modprobe.d/blacklist file:

blacklist padlock_aes
blacklist geode_aes

Source

Quite a few people have had success, so let me know. If no-go, I will do more digging for you.

share|improve this answer
1  
Further details on Linux support - thinkwiki.org/wiki/Cisco_Aironet_Wireless_802.11b –  paradroid Nov 25 '12 at 15:56
    
Would that blacklist.conf? –  baum Nov 25 '12 at 16:01
    
If that's what's there, probably. Just note what you changed so you can roll back if anything negative comes as a result. –  nerdwaller Nov 25 '12 at 18:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.