Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am on OS X and have a Windows 8 Consumer Preview x64 image. My computer doesn’t have a CD drive (MacBook Air). I have a 4 GB USB drive. I want to restore that image to the USB drive. There are many tools to do that on Windows, but I can’t finger out how to do it in OS X. Please note that I can’t run a VM, as my Air is a limited use machine.

What I’ve tried:

  • Simply restore to USB.
  • Convert the image to img and use dd.

These don’t work.

How do I go about doing this?

EDIT: Ok, everyone, really sorry for the confusion. I am new here.

To clear my motive, I am trying to create a bootable USB Windows 8 installer to install Windows 8 Consumer Preview (which apparently requires a product key, something I don’t have) so that I can use it later to install Windows 8 CP on my Mac Book Air. Using Bootcamp, according to what I have read and tried, is not an option. As suggested, I tried using Boot Camp Utility to prepare the USB drive, but unfortunately, that simply isn’t working and I can’t troubleshoot it.

share|improve this question
Why not dd the ISO...? Should work as dd if=/Users/username/Downloads/w8.iso of=/dev/sdX with images, some people try to specify a partition # where really you should do the disc so it acts as a udf volume. Also, please clarify "didn't work", meaning they did not boot or writing the image to USB failed...? – nerdwaller Nov 25 '12 at 18:08
Besides using dd, also ensure the partition has the boot flag set. – Karan Nov 25 '12 at 19:07
dding the ISO didn't help. I am on OS X and disks there are referred to as /dev/diskX and I wasn't specifying a partition number. Didn't work means didn't boot. All commands report that they are successful, but the disk can't be mounted. Booted up an Ubuntu Live USB and GParted says that there isn't a partition table on the drive. Weird. – duci9y Nov 25 '12 at 20:32
You should be able to use pretty much any tool to place the iso on the thumbdrive. Since you have a Windows installation I would use the Windows 7 tool that exactly this just on a Windows 8 iso. – Ramhound Nov 27 '12 at 19:36
@duci9y Yes, there would not be any partition table shown on the drive after dd, it would look like a UDF volume (similar to a CD). – nerdwaller Nov 28 '12 at 2:35

Prepare the USB key

We’re going to wipe the partition structure on the USB key. WARNING! THIS WILL DESTROY ALL DATA ON THE KEY!

Open up Disk Utility (it’s in /Applications/Utilities/).

Now do the following:

  1. Select the USB key (select the root device, not its partitions)
  2. Select the partition section at the top
  3. Change the Scheme to 1 Partition
  4. Change the Format to Free Space
  5. Click Apply

You will get a confirmation dialog appear ensuring you really want to delete all data on the key, choose Partition.

Once it’s completed you can quit out of Disk Utility.

The purpose of doing this is mainly to ensure that the USB key is in a consistent known state and also to ensure that any volumes are not mounted by OS X. It is not required and you can skip it if you’d rather just unmount the volumes yourself.

Preparing the ISO image

Now that our USB key is ready, we need to get our .iso image into a format that we can copy to it. Open up a Terminal (it too is in /Application/Utilities, and I’ll assume you know how to use the terminal)

Now, convert the image from a ISO to a Read/Write Universal Disk Image Format (or UDRW). Here I’m using the xbmc live repack ISO, but you can use anything else that’s an ISO file.

(#503:14u:0s) evan@8thwonder[/Users/evan/Downloads]: hdiutil convert -format UDRW -o xbmc-9.11-live-repack.img xbmc-9.11-live-repack.iso Reading XBMC_Live (Apple_ISO : 0)… ......................................................................................................................................................................................................... Elapsed Time: 24.475s Speed: 20.0Mbytes/sec Savings: 0.0% created: /Users/evan/Downloads/xbmc-9.11-live-repack.img.dmg

Once completed this will create the .img file. The hdiutil function likes to append a .dmg suffix to the file so it will probably end up .img.dmg after conversion.

Copy the image to the USB key

We’re finally here. The easy part, actually copying the image to the USB key.

First run diskutil list to get a listing of the disks in your machine so you can identify the USB key. It will look like this:

(#504:14u:0s) evan@8thwonder[/Users/evan/Downloads]: diskutil list /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *250.1 GB disk0 1: EFI 209.7 MB disk0s1 2: Apple_HFS Macintosh HD 249.7 GB disk0s2 /dev/disk1 #: TYPE NAME SIZE IDENTIFIER 0: *1.0 GB disk1

Here mine’s /dev/disk1.

We want to use the RAW disk device so that our copy will happen much faster because the RAW disk device provides unbuffered access to the device (See this Apple mailing list post for more info). This is accomplished by simply prepending ‘r’ to the device so that /dev/disk1 is going to become /dev/rdisk1

Next we use the dd command to copy the image over.

(#506:14u:0s) evan@8thwonder[/Users/evan/Downloads]: dd if=./xbmc-9.11-live-repack.img.dmg of=/dev/rdisk1 bs=1m

On the command line we specify the Input File using if= and the Output File using of= and dd will copy the data from input to output, block by block.

Once it’s completed you can exit Terminal and remove the USB key from your OS X machine, it should now be able to bootup your ISO on another machine.

NOTE: I wish I could take a credit for this, but I can't, here is the source.

share|improve this answer
This method was already tried, coincidentally from the exact same guide. – duci9y Nov 29 '12 at 13:13
@duci9y - Even if it worked you still need a product key. Have you tried the Windows 8 Enterprise iso? – Ramhound Nov 29 '12 at 13:34
@duci9y Well, at least I tried! Good luck! – George Nov 29 '12 at 16:06
+1 for rdisk#. I always wondered why dd was so slow on Apple computers.. – David Cowden Jun 23 '13 at 19:08
Remember to use unmountDisk before dd. rdisk will not work if it is mounted. – Austyn Mahoney Sep 9 '14 at 7:28

The Bootcamp utility will do this for you.

Edit: Are you trying to run Windows 8 from the USB drive? I think we were all reading your question as if you wanted to install from the USB drive. However, based on your claim that you don't want to install Windows, I'm wondering if you are looking for Windows To Go, which would allow you to boot and run Windows 8 from the USB drive without having it installed on the machine.

If that's what you're trying to do, then this article explains the process. You'll need a 32 GB or larger USB 3.0 drive and a machine that already has Windows 8 installed on it, so this might not work for you since you want something that runs on your Macbook Air and OS X.

Also, I believe Virtual Box will run on a machine that doesn't have hardware support for virtualization. Have you looked into that.

One other thing to note, there is a 90-day trial available for Windows 8 RTM, which might be a better option than the Consumer Preview if you just want to try it out.

share|improve this answer
I don’t want to install Windows, I want the installer image on a USB drive. – duci9y Nov 28 '12 at 13:17
@duci9y - If you don't want to install Windows, then what purpose, does the installer image on the USB drive serve exactly? – Ramhound Nov 28 '12 at 14:40
Bootcamp requires a product key, which I don’t have. I want to try out Windows, and got the Consumer Preview from “other” sources. – duci9y Nov 28 '12 at 16:22
@DennisPalmer Unless Windows 8 added this, you do not need a key to install. Solely to activate; however, you have 30 days until that is required. (Again, at least on W7, Vista and XP) – nerdwaller Nov 28 '12 at 20:01
@nerdwaller Windows 8 does require the product key during the install, you cannot skip this step any longer. Also, I remembered I tried to do exactly what the asker is doing, on OSX it just doesn't work to extract it to a USB stick, burn a DVD or use a Windows machine. – Brutick Nov 28 '12 at 20:04

I was having the same issue, just with Windows 7. However, I believe the problem (and the solution) is the same.

As none of the answers I found on the internet worked for me, here are the steps that I ended up following.

First of all, brief description of my setup:

  • I want to install Windows 7 (32-bit) on a PC (not on a Mac) using a USB removable media (8GB)
  • I have an ISO image of the installation DVD
  • I want to prepare the USB media on my Mac (OS X 10.10 Yosemite)
  • my MacBook Pro only has USB 3.0 ports

What I tried:

  • the typical suggestion of using hdiutil to convert ISO to UDRW IMG and then using dd to copy it to the USB. While I did not encounter any errors, the resulting USB media was not bootable.
  • using UNetbootin to create the media (supplying Windows installer ISO as custom ISO). While I did not encounter any errors and the resulting USB media seemed to be bootable, it just crashed during boot (started to boot then halted the system, no error).
  • using Windows inside VirtualBox to write to the USB stick did not work either, as VirtualBox does not support USB 3.0 yet (I even updated by VirtualBox to 5.0.0 RC1 but still no luck. Maybe newer versions will work)


As none of the above worked, I ended up first installing Ubuntu and then used that Ubuntu installation (it has GRUB2!) to create a bootable USB stick.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.